Last Comment Bug 701050 - Configuration error in Windows 8 Developer Preview when building browser
: Configuration error in Windows 8 Developer Preview when building browser
Status: RESOLVED WORKSFORME
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86_64 Windows 8
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks: VC11
  Show dependency treegraph
 
Reported: 2011-11-09 09:08 PST by Honza Bambas (:mayhemer)
Modified: 2015-04-16 12:55 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Honza Bambas (:mayhemer) 2011-11-09 09:08:53 PST
Setup:
- Windows 8 DP (up to this date) in VirtualBox
- mozilla-central
- install the MozillaBuild and update all the start bat files (in the mozilla-build root) with those in http://hg.mozilla.org/mozilla-build/ to build with VC11 (maybe that is the source of this bug?)

.mozconfig:
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/_obj-browser-debug
ac_add_options --enable-application=browser

console log:
/c/Mozilla/src/mozilla-central$ python -O build/pymake/make.py -f client.mk configure
make.py[0]: Entering directory 'c:\Mozilla\src\mozilla-central'
cd c:/Mozilla/src/mozilla-central/_obj-browser-debug
c:/Mozilla/src/mozilla-central/configure
Adding configure options from c:/Mozilla/src/mozilla-central/.mozconfig:
  --enable-application=browser
creating cache ./config.cache
checking host system type... i686-pc-mingw32
checking target system type... i686-pc-mingw32
checking build system type... i686-pc-mingw32
checking for mawk... no
checking for gawk... gawk
checking for perl5... no
checking for perl... /usr/bin/perl
checking for gcc... cl
checking whether the C compiler (cl  ) works... yes
checking whether the C compiler (cl  ) is a cross-compiler... no
checking whether we are using GNU C... no
checking whether cl accepts -g... no
checking for c++... cl
checking whether the C++ compiler (cl  ) works... yes
checking whether the C++ compiler (cl  ) is a cross-compiler... no
checking whether we are using GNU C++... no
checking whether cl accepts -g... no
checking for ranlib... :
checking for ml... /c/Program Files (x86)/Microsoft Visual Studio 11.0/VC/BIN/ml

checking for ar... no
checking for ld... link
checking for strip... no
checking for windres... no
checking for midl... midl
checking for midl flags... none needed
checking for winsdkver.h... no
checking for sdkddkver.h... yes
checking for std::_Throw... no
checking for overridable _RAISE... yes
checking for Windows SDK being recent enough... no
configure: error: You are targeting Windows version 0x06010000, but your SDK onl
y supports up to version 0x06000000. Install and use an updated SDK, or target a
 lower version using --with-windows-version. Alternatively, try running the Wind
ows SDK Configuration Tool and selecting a newer SDK. See https://developer.mozi
lla.org/En/Windows_SDK_versions for more details on fixing this.
*** Fix above errors and then restart with               "c:/Mozilla/mozilla-bui
ld/python/python.exe c:/Mozilla/src/mozilla-central/build/pymake/pymake/../make.
py -f client.mk build"
c:\Mozilla\src\mozilla-central\client.mk:315:0: command 'cd c:/Mozilla/src/mozil
la-central/_obj-browser-debug &&   c:/Mozilla/src/mozilla-central/configure  \
  || ( echo "*** Fix above errors and then restart with\
               \"c:/Mozilla/mozilla-build/python/python.exe c:/Mozilla/src/mozil
la-central/build/pymake/pymake/../make.py -f client.mk build\"" && exit 1 )' fai
led, return code 1



I'm getting this error in a clean DP environment and also after I've installed WIN SDK 7.1 + .NET 3.5.

To note: there is no HKLM\SOFTWARE\Microsoft\Microsoft SDKs\Windows\v8.0 entry.  It seems the SDK is simply not present or registered under a different location.  There is installation that claims to be SDK 8 in c:\Program Files (x86)\Microsoft SDKs\Windows\v8.0\ and v8.0A\, but the structure doesn't contain expected /lib and /include dirs, so it might be just some subset.
Comment 1 Honza Bambas (:mayhemer) 2011-11-14 10:45:19 PST
Any news here?  I'd really like to start building on Win8.
Comment 2 Gregory Szorc [:gps] 2011-11-14 11:35:45 PST
Can you provide your environment variables from the shell after running start-msvc11.bat? There is a potential for personal information to creep in there, so watch out.

 $ env
Comment 4 Honza Bambas (:mayhemer) 2011-11-15 08:34:02 PST
I start using c:\Mozilla\mozilla-build\start-msvc11.bat called via a bat file in c:\windows, cwd is c:\Mozilla\src\mozilla-central\.
Comment 6 Gregory Szorc [:gps] 2011-11-15 10:52:08 PST
Honza: Could you log into IRC so we can interact? Just ask for gps in the #introduction channel. I'm typically around between 1000 and 1900 PST. If I'm not around, someone else may be able to help. See https://wiki.mozilla.org/IRC for IRC instructions.
Comment 7 Gregory Szorc [:gps] 2011-11-15 15:09:21 PST
I was able to reproduce this exact error by:

1) Installing Windows 8 DP
2) Obtaining mozilla-central and latest mozilla-build with .bat files updated manually from HG
3) Create stub .mozconfig (application=browser, define objdir)
4) make -f client.mk configure

When I run start-msvc11.bat, I get:

  Using VC 2011 built-in SDK
  Mozilla build environment: MSVC version 11.

It seems to be picking up the Visual Studio Express environment which comes with Windows 8 DP. I /think/ everyone who has tested this to date had Visual Studio 2011 installed. So, I think we may need to do better error checking here.

I'm going to play with installing SDKs and Visual Studio in different orders to see if I can come up with a workaround.
Comment 8 Gregory Szorc [:gps] 2011-11-15 16:29:51 PST
Installing Visual Studio 2011 fixed this issue. When running configure, I now get:

  checking for highest Windows version supported by this SDK... 0x06020000
  checking for Windows SDK being recent enough... yes

I'm going to restore a snapshot from before VS2011 installation and see if installing a full SDK cleans this up as well.

I've updated https://developer.mozilla.org/en/Windows_8 with full build details. I have a build in progress and signs are hopeful!
Comment 9 Honza Bambas (:mayhemer) 2011-11-16 09:49:36 PST
Gregory, thanks for figuring this out.  I wasn't aware of the VS2011 DP availability.  It seems to work for me as well.  I only ran out of disk space during xullib linking :)  Disk with 30GB..
Comment 10 Gregory Szorc [:gps] 2011-11-16 15:38:15 PST
My VS2011 build on Windows 8 finished without any issue (used PyMake). However, firefox.exe crashes shortly after startup. Time to file another bug.
Comment 11 Jim Mathies [:jimm] 2012-07-13 20:19:05 PDT
resolving, if anyone is still having problems please reopen.
Comment 12 Sladky Vladimir 2013-09-02 23:43:25 PDT
FireFox (only 32 bit] now i build suscefully, but SeaMonkey not :-(
What problem please if 'mapix.h not exist ?

c:\users\vlada\comm-central\mailnews\addrbook\src\nsAbWinHelper.h(9) : fatal error C1083: Cannot open include file: 'mapix.h': No such file or directory
Comment 13 Armen Zambrano [:armenzg] (EDT/UTC-4) 2015-04-16 12:19:02 PDT
This bug is still referenced in here:
https://developer.mozilla.org/en-US/docs/Windows_8

Could someone please have a look at the doc and update it?
Thanks!

Note You need to log in before you can comment on or make changes to this bug.