Closed Bug 701130 Opened 9 years ago Closed 9 years ago

Firefox 11.0a1 Crash Report [@ JSObject::getGlobal ]

Categories

(Core :: JavaScript Engine, defect)

x86
All
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 689118

People

(Reporter: overlordq, Unassigned)

Details

(Keywords: crash, topcrash)

Crash Data

User Agent: Mozilla/5.0 (X11; Linux i686; rv:11.0a1) Gecko/20111109 Firefox/11.0a1
Build ID: 20111109031111

Steps to reproduce:

Might be related to bug 689118 as it also involves Firebug, this appears to happen when reloading a page with the script debugger open.


Actual results:

Firefox Crashed


Expected results:

Firefox not crash
0 	libxul.so 	JSObject::getGlobal 	js/src/jsobj.h:945
1 	libxul.so 	js::AutoCompartment::enter 	js/src/jswrapper.cpp:456
2 	libxul.so 	JS_EnterCrossCompartmentCall 	js/src/jsapi.cpp:1303
3 	libxul.so 	jsd_GetValueString 	js/jsd/jsd_val.c:232
4 	libxul.so 	jsd_GetValueProperty 	js/jsd/jsd_val.c:594
5 	libxul.so 	jsdValue::GetProperty 	js/jsd/jsd_xpc.cpp:2425
6 	libxul.so 	libxul.so@0xf2355b 	
7 	libxul.so 	XPCWrappedNative::CallMethod 	js/xpconnect/src/XPCWrappedNative.cpp:2882
8 	libxul.so 	XPC_WN_CallMethod 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp:1554
9 	libxul.so 	js::InvokeKernel 	js/src/jscntxtinlines.h:297
10 	libxul.so 	js::Interpret 	js/src/jsinterp.cpp:3948
11 	libxul.so 	UncachedInlineCall 	js/src/methodjit/InvokeHelpers.cpp:392
12 	libxul.so 	js::mjit::stubs::UncachedCallHelper 	js/src/methodjit/InvokeHelpers.cpp:479
13 	libxul.so 	js::mjit::stubs::UncachedCall 	js/src/methodjit/InvokeHelpers.cpp:433
14 		@0x4c78db7 	
15 	libxul.so 	libxul.so@0x1681277 	
16 	libxul.so 	js::mjit::EnterMethodJIT 	js/src/methodjit/MethodJIT.cpp:1064
17 	libxul.so 	js::mjit::JaegerShotAtSafePoint 	js/src/methodjit/MethodJIT.cpp:1125
18 	libxul.so 	js::Interpret 	js/src/jsinterp.cpp:2125
19 	libxul.so 	js::InvokeKernel 	js/src/jsinterp.cpp:647
20 	libxul.so 	js::Invoke 	js/src/jsinterp.h:148
21 	libxul.so 	js_fun_apply 	js/src/jsfun.cpp:1817
22 	libxul.so 	js::mjit::stubs::UncachedCallHelper 	js/src/jscntxtinlines.h:297
23 	libxul.so 	js::mjit::stubs::UncachedCall 	js/src/methodjit/InvokeHelpers.cpp:433
24 		@0x40eb325 	
25 	libxul.so 	libxul.so@0x1681277 	
26 	libxul.so 	js::mjit::JaegerShot 	js/src/methodjit/MethodJIT.cpp:1064
27 	libxul.so 	js::RunScript 	js/src/jsinterp.cpp:581
28 	libxul.so 	js::InvokeKernel 	js/src/jsinterp.cpp:647
29 	libxul.so 	js::Invoke 	js/src/jsinterp.h:148
30 	libxul.so 	JS_CallFunctionValue 	js/src/jsapi.cpp:5199
31 	libxul.so 	nsXPCWrappedJSClass::CallMethod 	js/xpconnect/src/XPCWrappedJSClass.cpp:1530
32 	libxul.so 	nsXPCWrappedJS::CallMethod 	js/xpconnect/src/XPCWrappedJS.cpp:611
33 	libxul.so 	PrepareAndDispatch 	xptcstubs_gcc_x86_unix.cpp:92
34 	libxul.so 	jsds_ExecutionHookProc 	js/jsd/jsd_xpc.cpp:694
35 	libxul.so 	jsd_CallExecutionHook 	js/jsd/jsd_hook.c:177
36 	libxul.so 	jsd_ThrowHandler 	js/jsd/jsd_hook.c:148
37 	libxul.so 	js::Interpret 	js/src/jsinterp.cpp:5950
38 	libxul.so 	js::ExecuteKernel 	js/src/jsinterp.cpp:783
39 	libxul.so 	js::Execute 	js/src/jsinterp.cpp:822
40 	libxul.so 	EvaluateUCScriptForPrincipalsCommon 	js/src/jsapi.cpp:5093
41 	libxul.so 	JS_EvaluateUCScriptForPrincipalsVersion 	js/src/jsapi.cpp:5105
42 	libxul.so 	nsJSContext::EvaluateString 	dom/base/nsJSEnvironment.cpp:1490
43 	libxul.so 	nsScriptLoader::EvaluateScript 	content/base/src/nsScriptLoader.cpp:905
44 	libxul.so 	nsScriptLoader::ProcessRequest 	content/base/src/nsScriptLoader.cpp:799
45 	libxul.so 	nsScriptLoader::ProcessScriptElement 	content/base/src/nsScriptLoader.cpp:745
46 	libxul.so 	nsScriptElement::MaybeProcessScript 	content/base/src/nsScriptElement.cpp:182
47 	libxul.so 	nsHTMLScriptElement::MaybeProcessScript 	content/html/content/src/nsHTMLScriptElement.cpp:349
48 	libxul.so 	nsHTMLScriptElement::DoneAddingChildren 	content/html/content/src/nsHTMLScriptElement.cpp:276
49 	libxul.so 	nsHtml5TreeOpExecutor::RunScript 	parser/html/nsHtml5TreeOpExecutor.cpp:772
50 	libxul.so 	nsHtml5TreeOpExecutor::RunFlushLoop 	parser/html/nsHtml5TreeOpExecutor.cpp:567
51 	libxul.so 	nsHtml5ExecutorReflusher::Run 	parser/html/nsHtml5TreeOpExecutor.cpp:94
52 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:631
53 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:245
54 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:110
55 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:208
56 	libxul.so 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:189
57 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:228
58 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3551
59 	firefox 	main 	browser/app/nsBrowserApp.cpp:198
60 	libc-2.11.1.so 	libc-2.11.1.so@0x16bd5 	
61 	firefox 	firefox@0x14d0 	
62 	firefox 	firefox@0x15ff 	
63 	ld-2.11.1.so 	ld-2.11.1.so@0xe02f 	
64 	ld-2.11.1.so 	ld-2.11.1.so@0x1c8f7
Severity: normal → critical
Crash Signature: [@ JSObject::getGlobal ]
Keywords: crash
Crash Signature: [@ JSObject::getGlobal ] → [@ JSObject::getGlobal ] [@ JSObject::getGlobal() ]
Crashes on Windows happen mainly at startup.
Assignee: nobody → general
Status: UNCONFIRMED → NEW
Component: General → JavaScript Engine
Ever confirmed: true
OS: Linux → All
Product: Firefox → Core
QA Contact: general → general
Version: 11 Branch → Trunk
It's #3 top browser crasher in 9.0.1 on Mac OS X.
All Mac crashes are correlated to Firebug.
Keywords: topcrash
Scoobi, is the mac version of this crash new in 9?
(In reply to [:Cww] from comment #5)
> Scoobi, is the mac version of this crash new in 9?
The Mac crash signature summary shows it also happened in 8.0.1:
https://crash-stats.mozilla.com/report/list?signature=JSObject%3A%3AgetGlobal
Although it's only #140 Mac top crasher in 8.0.1 on Mac OS X.
So there's a regression in Fx 9.

According to stack traces and the Firebug correlation, it's a dupe of bug 689118 which is fixed in Fx 12.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 689118
This signature is now by far #1 on 8.* - I wonder if this is something else or not, we don't have good correlation reports apparently.
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #7)
> This signature is now by far #1 on 8.* - I wonder if this is something else
> or not, we don't have good correlation reports apparently.

Looks like this is the current incarnation of bug 691847.
You need to log in before you can comment on or make changes to this bug.