Last Comment Bug 701260 - Deny requests for DOM full-screen when windowed plugins are present in the entire doc tree
: Deny requests for DOM full-screen when windowed plugins are present in the en...
Status: RESOLVED FIXED
[inbound][qa?]
:
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: 10 Branch
: All All
: -- normal (vote)
: mozilla10
Assigned To: PTO until Sep 5 NZ time; Chris Pearce (:cpearce)
:
Mentors:
Depends on:
Blocks: 545812 684618
  Show dependency treegraph
 
Reported: 2011-11-09 18:13 PST by PTO until Sep 5 NZ time; Chris Pearce (:cpearce)
Modified: 2012-02-01 13:00 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
Patch (2.36 KB, patch)
2011-11-15 17:15 PST, PTO until Sep 5 NZ time; Chris Pearce (:cpearce)
roc: review+
christian: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description PTO until Sep 5 NZ time; Chris Pearce (:cpearce) 2011-11-09 18:13:17 PST
Currently the check which prevents us going full-screen when a doctree contains a windowed plugin only checks the document and its subdocuments, whereas it should check every document in the target document's branch (but not in other branches/tabs).
Comment 1 PTO until Sep 5 NZ time; Chris Pearce (:cpearce) 2011-11-15 17:15:59 PST
Created attachment 574747 [details] [diff] [review]
Patch

Change to deny requests for full-screen if any doc in the tab has a windowed plugin, rather than if the requesting doc or its subdocs have windowed plugins.

I have tests, but the tests leak on tryserver (even without this patch applied!), so I'll not put the tests up for review.
Comment 2 PTO until Sep 5 NZ time; Chris Pearce (:cpearce) 2011-11-15 18:15:38 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/67d6b8636246
Comment 3 Ed Morley [:emorley] 2011-11-16 03:09:40 PST
https://hg.mozilla.org/mozilla-central/rev/67d6b8636246
Comment 4 PTO until Sep 5 NZ time; Chris Pearce (:cpearce) 2011-11-16 16:53:19 PST
Comment on attachment 574747 [details] [diff] [review]
Patch

Requesting approval for Aurora, because this fix prevents a work-around which enables keyboard input in full-screen mode which doesn't cause the "Press ESC to leave full-screen mode" warning to pop up. We need this to help protect against phishing attacks.
Comment 5 christian 2011-11-17 14:47:34 PST
Comment on attachment 574747 [details] [diff] [review]
Patch

[triage comment]
Approved for aurora. Please land as soon as possible
Comment 6 PTO until Sep 5 NZ time; Chris Pearce (:cpearce) 2011-11-17 15:05:18 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/43e4a46ca7dc
Comment 7 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-12-28 14:10:37 PST
Is this something QA can verify?
Comment 8 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-02-01 12:58:17 PST
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #7)
> Is this something QA can verify?

bump

Note You need to log in before you can comment on or make changes to this bug.