Last Comment Bug 701285 - No favicons display after loading pages
: No favicons display after loading pages
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P1 normal (vote)
: ---
Assigned To: :Margaret Leibovic
:
Mentors:
: 701801 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-09 21:06 PST by Mark Finkle (:mfinkle) (use needinfo?)
Modified: 2012-01-09 11:58 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
patch (1.50 KB, patch)
2011-11-10 15:41 PST, :Margaret Leibovic
pwalton: review+
Details | Diff | Splinter Review

Description Mark Finkle (:mfinkle) (use needinfo?) 2011-11-09 21:06:35 PST
Since the layers panning and zooming code landed, I no longer see favicons being loaded/displayed in the URL bar. I do see the favicon messages in logcat, letting me know the favicon was discovered.
Comment 1 :Margaret Leibovic 2011-11-10 15:41:59 PST
Created attachment 573680 [details] [diff] [review]
patch

A JSONException is getting thrown because the DOMContentLoaded event doesn't have a pageSize property. This meant that handleContentLoaded is never getting called, and that's where loadFavicon is called. jsonPageSize isn't even being used anywhere, so I just removed this line.

Asking Patrick for review since this was introduced by https://hg.mozilla.org/projects/birch/rev/eaf778e88070.
Comment 2 Patrick Walton (:pcwalton) 2011-11-10 20:23:19 PST
Comment on attachment 573680 [details] [diff] [review]
patch

Doh, good catch.
Comment 3 :Margaret Leibovic 2011-11-11 10:08:13 PST
https://hg.mozilla.org/projects/birch/rev/e65b9655e3e8
Comment 4 Aaron Train [:aaronmt] 2011-11-11 11:22:56 PST
20111111100727
http://hg.mozilla.org/projects/birch/rev/e65b9655e3e8
(Samsung Galaxy SII Android 2.3.4)
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-11 12:00:51 PST
*** Bug 701801 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.