Closed Bug 701345 Opened 8 years ago Closed 8 years ago

web worker from blob url no longer works in ffx8.0

Categories

(Firefox :: General, defect)

8 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 699633

People

(Reporter: sfornengo, Unassigned)

Details

Attachments

(1 file)

611 bytes, text/plain
Details
Attached file test.html
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928224508

Steps to reproduce:

a basic worker sample from blob url:
<!DOCTYPE html>
<html>
<head><meta charset="utf-8" /></head>
<body>
  <script>
	var _BlobBuilder=window.BlobBuilder || window.MozBlobBuilder || window.WebKitBlobBuilder;
	var _URL=window.URL || window.webkitURL;
    var bb = new _BlobBuilder();
    bb.append("onmessage=function(e){postMessage('msg from worker');};");
	var blobURL=_URL.createObjectURL(bb.getBlob());
    var worker = new Worker(blobURL);
    worker.onmessage=function(e) {
      console.log(e.data);
    }
	worker.onerror=function(e){
		console.log(e.data);
	};
    worker.postMessage(""); // Start the worker.
  </script>
</body>
</html>


Actual results:

get error:
[14:07:21,418] Failed to load script: moz-filedata:d791db10-20d1-4967-b236-24ec3d2a6666 (nsresult = 0x80004002)
works fine in ffx 7.0
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 699633
You need to log in before you can comment on or make changes to this bug.