Last Comment Bug 701347 - scratchpad (orion): ctrl-v, Edit/Paste, Right Menu Paste all do not paste
: scratchpad (orion): ctrl-v, Edit/Paste, Right Menu Paste all do not paste
Status: RESOLVED FIXED
[sourceeditor][orion]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Scratchpad (show other bugs)
: Trunk
: All All
: P2 normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 718816
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-10 05:26 PST by Stefan
Modified: 2012-02-22 12:36 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Stefan 2011-11-10 05:26:01 PST
User Agent:  

Steps to reproduce:

1. Open scrachpad.
2. With the mouse select "Right" in line 4. Ctrl-C.
3. Move cursor to line 10
4. Press ctrl-v, invoke Edit/Paste and right mouse menu/paste.


Actual results:

4. No paste.


Expected results:

4. Paste "Right".

Built from https://hg.mozilla.org/mozilla-central/rev/c60535115ea1
(copy/paste in location bar, input fields etc. works).
Comment 1 Rob Campbell [:rc] (:robcee) 2012-01-12 11:23:41 PST
yup. able to reproduce in current nightly on mac.
Comment 2 Mihai Sucan [:msucan] 2012-01-12 13:46:07 PST
Stefan: thanks for your bug report!

We really need a fix for bug 407983...
Comment 3 Mihai Sucan [:msucan] 2012-01-25 08:50:22 PST
Bug triage. Filter on PEGASUS.
Comment 4 Mihai Sucan [:msucan] 2012-02-10 10:28:53 PST
I can semi-reproduce this bug: Edit > Paste works for me, but Right click > Paste fails.

With the patch for bug 718816 I also get the context menu Paste menu item working fine.

Rob: can you please retest? Thank you!

I hope this bug is fixed by the Orion update I have prepared.
Comment 5 Mihai Sucan [:msucan] 2012-02-22 12:36:12 PST
This bug should be fixed now. Please reopen if the problem persists. Thank you!

Note You need to log in before you can comment on or make changes to this bug.