Last Comment Bug 701361 - Add a telemetry probe for finding out how commonly multipart XHR is used on the Web
: Add a telemetry probe for finding out how commonly multipart XHR is used on t...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla14
Assigned To: Henri Sivonen (:hsivonen)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: 843508
  Show dependency treegraph
 
Reported: 2011-11-10 07:25 PST by Henri Sivonen (:hsivonen)
Modified: 2013-02-21 01:23 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add boolean telemetric for multipartness (2.73 KB, patch)
2011-12-19 04:34 PST, Henri Sivonen (:hsivonen)
bugs: review+
Details | Diff | Splinter Review

Description Henri Sivonen (:hsivonen) 2011-11-10 07:25:18 PST
The current multipart XHR code doesn't work nicely with off-the-main-thread parsing. This is a problem with HTML now and will be a problem with XML in the future.

If multipart responses aren't actually used, maybe we could drop multipart support. Let's gather data in order to make an informed decision.
Comment 1 Henri Sivonen (:hsivonen) 2011-12-19 04:34:45 PST
Created attachment 582790 [details] [diff] [review]
Add boolean telemetric for multipartness

Do telemetry additions always require privacy review?
Comment 2 Olli Pettay [:smaug] 2011-12-19 04:38:06 PST
Comment on attachment 582790 [details] [diff] [review]
Add boolean telemetric for multipartness

I'm sure multipart is used extremely rarely.
Comment 3 Henri Sivonen (:hsivonen) 2011-12-19 05:18:42 PST
It seems like a no-brainer that this is OK under the privacy policy, but since I'm not sure what the rules are about landing telemetry probes wrt. privacy review, adding privacy-review-needed.
Comment 4 Curtis Koenig [:curtisk-use curtis.koenig+bzATgmail.com]] 2012-02-21 10:00:22 PST
this is clearly feature usage, removing privacy flags
Comment 5 Henri Sivonen (:hsivonen) 2012-03-28 00:35:22 PDT
Oops. Forgot to land this. Thanks for the reviews.
https://hg.mozilla.org/integration/mozilla-inbound/rev/5fde420239cd
Comment 6 Ed Morley [:emorley] 2012-03-28 14:00:32 PDT
https://hg.mozilla.org/mozilla-central/rev/5fde420239cd

Note You need to log in before you can comment on or make changes to this bug.