in awesomescreen, horizontal swiping should switch between categories

RESOLVED DUPLICATE of bug 759041

Status

()

P5
normal
RESOLVED DUPLICATE of bug 759041
7 years ago
6 years ago

People

(Reporter: madhava, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
(Reporter)

Comment 1

7 years ago
Hm. That went through without a description. :(

As seems to be standard on ICS, side-to-side swiping in the awesomescreen should switch between the categories (All, Bookmarks, History, etc.).
(In reply to Madhava Enros [:madhava] from comment #1)
> Hm. That went through without a description. :(
> 
> As seems to be standard on ICS, side-to-side swiping in the awesomescreen
> should switch between the categories (All, Bookmarks, History, etc.).

Do we know if this is "standard"/built-in feature for any TabHost on ICS? If it is, then I think we do nothing. We don't need to backport Android features to older versions of Android.
(In reply to Mark Finkle (:mfinkle) from comment #2)
> (In reply to Madhava Enros [:madhava] from comment #1)
> > Hm. That went through without a description. :(
> > 
> > As seems to be standard on ICS, side-to-side swiping in the awesomescreen
> > should switch between the categories (All, Bookmarks, History, etc.).
> 
> Do we know if this is "standard"/built-in feature for any TabHost on ICS? If
> it is, then I think we do nothing. We don't need to backport Android
> features to older versions of Android.

ICS' source code is not available yet so I have no way to confirm that but, AFAIK, yes, TabHost in ICS has swipe gesture support by default.
Let's wait until we know the story with ICS
Priority: -- → P5
So what's the story on ICS? I'm missing this gesture, as it feels very natural.
OS: Mac OS X → Android
Hardware: x86 → ARM
(In reply to Gian-Carlo Pascutto (:gcp) from comment #5)
> So what's the story on ICS? I'm missing this gesture, as it feels very
> natural.

We need to include the Android support package in our APK to get ViewPager and fragments support support that is backwards-compatible with Android >= 1.6. Then it's just a matter of re-structuring the awesomebar screen to use those APIs.

My assumption above (comment #3) was unfortunately wrong. TabHost does not give us swiping gestures support for free on ICS. We need to use a combination of tabhost (or ActionBar tabs) and ViewPager to get that.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 759041
You need to log in before you can comment on or make changes to this bug.