Closed Bug 701396 Opened 10 years ago Closed 10 years ago

trunk crash in JSC::Yarr::Interpreter::interpret

Categories

(Core :: JavaScript Engine, defect)

10 Branch
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
mozilla10

People

(Reporter: kairo, Unassigned)

References

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-2573bdd4-21f4-4c6f-870a-cbcea2111110 .
============================================================= 

https://crash-stats.mozilla.com/report/list?signature=JSC%3A%3AYarr%3A%3AInterpreter%3A%3Ainterpret%28%29 shows a long list of crashes happening in 11.0a1 trunk, mainly in builds from 2011-11-09, but it somehow looks like we never did shake off bug 694752 completely.

In the report noted here specifically, the user commented that (s)he "was just going into Zoo World on facebook and it closed completely", other mention they were organizing/opening tabs or going to some website, so this really smells like something triggered by web content.
OS: Linux → Windows 7
Hardware: x86_64 → x86
https://crash-stats.mozilla.com/report/list?signature=js%3A%3ARegExpPrivate%3A%3Adecref%28JSContext*%29 might be crashes that are also related to this, though that one only started on builds from 2001-11-08, so marks a clear regression.
Adding Mac specific signature.
Crash Signature: [@ JSC::Yarr::Interpreter::interpret()] → [@ JSC::Yarr::Interpreter::interpret()] [@ JSC::Yarr::interpret ]
OS: Windows 7 → All
Hardware: x86 → All
Got this one twice today, and also bug 701399 once.  I've trying to narrow it down and highly suspect it happens after this link has been open for about 5~10 minutes:
http://store.sony.com/webapp/wcs/stores/servlet/CategoryDisplay?catalogId=10551&storeId=10151&langId=-1&categoryId=32334
I hit this a few times today using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0a2) Gecko/20111112 Firefox/10.0a2.
I got this crash on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0a1) Gecko/20111111 Firefox/11.0a1.  

STR i head: resizing a popup window that was loading Yahoo Fantasy football stattracker.

http://crash-stats.mozilla.com/report/index/bp-33702e53-89cc-4165-8fcc-58b3d2111113
http://crash-stats.mozilla.com/report/index/bp-ba22ae4c-c9b4-4e06-b350-af3782111113
It's happen to me too. Firefox crash in facebook.
http://crash-stats.mozilla.com/report/index/bp-126410b2-ce59-4e2b-9115-14b4b2111114
It's #1 top crasher in 10.0a2 and 11.0a1.
The spike started in the new branches: 10.0a2/20111109, 11.0a1/20111109.
Keywords: regression
Version: Trunk → 10 Branch
We had (almost) no crashes on trunk with this signature with builds from 2011-11-15 or -16 yet, the last ones we have are from -14 builds. In fact there's a single crash with a build from the 15th, but that may not be an official nightly.
See "Table" tab in https://crash-stats.mozilla.com/report/list?product=Firefox&version=Firefox%3A11.0a1&signature=JSC%3A%3AYarr%3A%3AInterpreter%3A%3Ainterpret%28%29 - we had way over 300 crashes with builds from days before that.
I received this crash as well.  Yesterday and today again.  

https://crash-stats.mozilla.com/report/index/bp-574ce29a-fd2d-4813-b420-c95e82111116

Let me know if you need more info.
Nothing on 10.0a2 since 20111116042011. Nothing on 9.0 since 20111116091359. Probably fixed by backout of bug 702426.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla10
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.