Closed Bug 701404 Opened 9 years ago Closed 8 years ago

Silverlight crashiness using Bing Video

Categories

(Core :: Plug-ins, defect)

9 Branch
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox8 --- affected
firefox9 + affected
firefox10 + affected
firefox11 + affected

People

(Reporter: vlad.ghetiu, Assigned: smichaud)

Details

(Keywords: qawanted, Whiteboard: [qa+] STR in comment #16)

Attachments

(6 files)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0) Gecko/20100101 Firefox/9.0 beta 1

Silverlight plugin keeps on crashing on MAC OS X 10.7

Steps to reproduce:

1. In Firefox 9.0 beta 1
2. Go to http://www.bing.com/videos/browse and play any movie.

Actual results:
The video doesn't play, instead you get a silverlight crash error.

Expected results:
The video should play.
What version of Silverlight are you using?

Does this also happen with today's mozilla-central nightly?
Do you get a crash report notice with the silverlight crash error? If so, can you look in about:crashes and give us the crash report IDs?
Whiteboard: [qa+]
Keywords: qawanted
I am not able to reproduce a crash on that site using Version: 4.0.60831.0 and Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0) Gecko/20100101 Firefox/9.0.
Akin to Marcia -- unable to reproduce.

--
OS X (10.7.2)
Silverlight 4.0.60831.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0) Gecko/20100101 Firefox/9.0
I tried with 4.0.60531.0 and 4.0.60831.0 (the latter is the latest). No crashes yet.
I'll try on latest nightly and see if the problem persists.
I have tried reproducing this on:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0) Gecko/20100101 Firefox/9.0 beta 1
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:10.0a2) Gecko/20111113 Firefox/10.0a2
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:11.0a1) Gecko/20111113 Firefox/11.0a1

I've updated Silverlight to the last version: 4.0.60831.0 and I got no crashes for some time. After watching several clips, Firefox, Aurora and Nightly crashed with the same Silverlight crash error.
After reloading the page, the clips played as expected.
Most of the time the videos are playing as expected but from time to time I get an Silverlight crash. 
I don't have clear steps to reproduce this.
Would it be possible for you to provide some crash data Vlad? Either links to or plain-text copies of crash reports.
Attached image screenshot
I got another crash on Firefox 8.0.1:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:8.0.1) Gecko/20100101 Firefox/8.0.1

You can see in the attachment the screenshot of the crash.
No report is available.
Are you able to reproduce this on more than one machine?
Vlad is this a regression from 8.0?
Testing with Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:8.0.1) Gecko/20100101 Firefox/8.0.1 and Version: 4.0.60831.0 I was able to generate a Silverlight plugin crash on the Bing videos site.

STR:
1. Play a bing video. Stop that video with the controls.
2. Play another bing video. Crash with no report available.

I will attach the apple report as well.
I have not been able to reproduce the problem on 8.0 nor 8.0.1 with the latest Silverlight version on 10.7.1 nor 10.7.2 on a Mac Mini and Macbook Air. I've had videos playing for a half hour now, and no problem so far.
Using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:8.0.1) Gecko/20100101 Firefox/8.0.1 on a Mac Mini I haven't yet been able to generate a Silverlight crash visiting some bing videos as well as http://tennis.uxclip.com/. Will report back if I see a crash using Version: 4.0.60831.0.
I think I have found a way of reproducing the crash. 

Play the clips in a rapid succesion. Click on one clip, wait for 2-3 second and then click on another, wait 2-3 second and then click on another and so on.
The silverlight should crash. Have in mind that clicking in a rapid succesion, the crash will appear briefly in the video player, and another movie will start.
Another thing that I observed on Mac OS X 10.6 and also 10.7 was that even though silverlight didn't crash so often, Firefox keept on freezing for several seconds.

On Win 7 x32:
-Firefox 8 - CRASHED
-Firefox 8.0.1 - CRASHED
-Firefox 9b1 - CRASHED

On Win 7 x64:
-Firefox 8 - DIDN'T CRASH
-Firefox 8.0.1 - DIDN'T CRASH
-Firefox 9b1 - CRASHED

On Win XP:
-Firefox 8 - DIDN'T CRASH
-Firefox 8.0.1 - CRASHED
-Firefox 9b1 - CRASHED

On Win MacOS X 10.6:
-Firefox 8 - CRASHED 
-Firefox 8.0.1 - DIDN'T CRASH
-Firefox 9b1 - DIDN'T CRASH

On Win MacOS X 10.7:
-Firefox 8 - DIDN'T CRASH 
-Firefox 8.0.1 - DIDN'T CRASH
-Firefox 9b1 - CRASHED
I've got another crash on Firefox 8.0.1 build 2 following the steps from comment16:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0.1) Gecko/20100101 Firefox/8.0.1 build 2
Given that we are half-way through the 9.0 Beta cycle, what is needed to escalate this issue?
Juan and I have not been able to reproduce consistently. I don't see that we ever got an answer to which Silverlight version Vlad was using.

We should do some further testing on the latest 9 beta. I will try some Bing videos as well as some other sites. But we really need people to be very specific about Mac OS version as well as Silverlight version when reporting results.
I'll see if I can come up with a way for them to test this tonight.
In the QA lab I was running simultaneously on Win 7 X64 and Mac 10.7.2 and I only got one crash with Beta 5 on Win 7 but could not reproduce. I tried clicking the videos quickly in rapid succession. When I go back down after my meeting I will paste the Silverlight versions.
Hi guys.

This time Firefox 9b5 crashed. This is the Report ID from about:crashes
bp-9c539e8d-9cd8-4b0f-be1a-a0a6e2111209

My Silverlight plug-in is: 4.0.60831.0

Firefox build: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0) Gecko/20100101 Firefox/9.0

Use the steps from comment16 in order to reproduce this bug.
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0) Gecko/20100101 Firefox/9.0
Silverlight plug-in: 4.0.60831.0

If videos are played in rapid succession as described in comment #16 (click on one clip, wait for 2-3 second and then click on another, wait 2-3 second and then click on another and so on), after a while the video won't change (same video will continue to play, regarding which one is selected) and user cannot watch other videos until page is reloaded.
Could not get silverlight plugin to crash.
Firefox 9b5 has crashed on MacOS X 10.7.2.

This is the Report ID from about:crashes
bp-61aec8d4-afc8-4e48-a4d5-6aab42111209
bp-3a82ca6f-4034-46bd-a5f5-2cbb92111209

Firefox crashes almost every time using the steps from comment16
See also comment23.

My Silverlight plug-in is: 4.0.60831.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:9.0) Gecko/20100101 Firefox/9.0 beta 5
Mozilla/5.0 (Windows NT 5.1; rv:9.0) Gecko/20100101 Firefox/9.0
BuildID: 20111206234556
Silverlight plugin Version: 4.0.60831.0

The Silverlight plugin also crashes on Windows XP with steps very similar to those from  comment 16 (click on one clip, wait until it starts loading, then click on another clip before the first one starts playing; wait until it starts loading, then click on a third clip before the second one starts playing, and so on).
Ioana, do you get the same crash signatures as Vlad reported? or are you getting a different crash signature. We might be looking at two different bugs here with similar symptoms.
It appears like the crash dumps are corrupted:
[@ EMPTY: no crashing thread identified; corrupt dump ]
Here's a wild guess:

Infinite regression crashes often have corrupt stacks.  I just fixed an infinite regression crash at bug 708278.

Vlad, please try the tryserver build of my patch for bug 708278, available at bug 708278 comment #11.
> Infinite regression

Infinite regression -> infinite recursion :-)
Hi Steven

I have tried the link from bug 708278 comment #11 and I get a 404 Not Found error.
Can you please provide another link for the try build?
Thanks.

(In reply to Steven Michaud from comment #29)
> Here's a wild guess:
> 
> Infinite regression crashes often have corrupt stacks.  I just fixed an
> infinite regression crash at bug 708278.
> 
> Vlad, please try the tryserver build of my patch for bug 708278, available
> at bug 708278 comment #11.
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #27)
> Ioana, do you get the same crash signatures as Vlad reported? or are you
> getting a different crash signature. We might be looking at two different
> bugs here with similar symptoms.

Anthony, the Silverlight plugin crashes on Windows XP not the browser (the browser didn't crash nor froze). I don't see how I can get the plugin crash signature but if that is what you need and it is possible, please let me know how it can be found.
Ioana, how do you mean the plugin crashes on Windows and not the browser? Are you getting the Firefox plug-in crash reporter? Is there some other OS-level crash dialog? Please explain what you are experiencing.
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #33)
> Ioana, how do you mean the plugin crashes on Windows and not the browser?
> Are you getting the Firefox plug-in crash reporter? Is there some other
> OS-level crash dialog? Please explain what you are experiencing.

Anthony, what I meant in my previous comment is that, on Windows XP, the plugin crashes in the browser, the browser itself doesn't crash. There is no report for this crash. Please see the attached screen shot for more details.
To be clear, Vlad, are you seeing the same thing (comment 34) on Mac OS X 10.7?
Hi Anthony.

Yes, I see the same bug as in comment34.

Now though, when I try to reproduce this bug on Firefox 9 beta 5 on Mac OS X 10.7.2 I see this crash together with a Firefox crash. 
This two crashes are not connected, sometimes Silverlight crashes, sometimes Firefox 9b5.
I've notice this behavior only on Mac OS X 10.7.2 - see comment25.
Okay, given that the data cannot be correlated as of yet, we could be looking at different crashes here. Unfortunately, without crash data there is no way to prove that either way. I'm renaming this bug to capture the global problem.
OS: Mac OS X → All
Hardware: x86 → All
Summary: Silverlight plugin keeps on crashing on MAC OS X 10.7 → Silverlight crashiness using Bing Video
(In reply to comment #31)

> I have tried the link from bug 708278 comment #11 and I get a 404 Not Found error.
> Can you please provide another link for the try build?
> Thanks.

That build was only done six days ago, on 2011/12/07, but now it's gone.  I don't know whether it was deleted, or whether this is yet another symptom of our recent server-farm problems.

I'll have to do another build.  It should be available later today.
Vlad: If you are getting a browser crash can we please get the report ID from about:crashes?

(In reply to Vlad [QA] from comment #37)
> Hi Anthony.
> 
> Yes, I see the same bug as in comment34.
> 
> Now though, when I try to reproduce this bug on Firefox 9 beta 5 on Mac OS X
> 10.7.2 I see this crash together with a Firefox crash. 
> This two crashes are not connected, sometimes Silverlight crashes, sometimes
> Firefox 9b5.
> I've notice this behavior only on Mac OS X 10.7.2 - see comment25.
Hi Marcia

I've posted the crash ID in comment25
 
(In reply to Marcia Knous [:marcia] from comment #40)
> Vlad: If you are getting a browser crash can we please get the report ID
> from about:crashes?
> 
> (In reply to Vlad [QA] from comment #37)
> > Hi Anthony.
> > 
> > Yes, I see the same bug as in comment34.
> > 
> > Now though, when I try to reproduce this bug on Firefox 9 beta 5 on Mac OS X
> > 10.7.2 I see this crash together with a Firefox crash. 
> > This two crashes are not connected, sometimes Silverlight crashes, sometimes
> > Firefox 9b5.
> > I've notice this behavior only on Mac OS X 10.7.2 - see comment25.
Hi Steven.

I have tried this with the build that you provided but Nightly keeps on crashing.
Here are the Report IDs:

bp-c62b0348-f4bd-4f6c-bfc4-9faef2111213
bp-419a82ac-7264-4583-9445-560292111213

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0a1) Gecko/20111212 Firefox/11.0a1


(In reply to Steven Michaud from comment #41)
> (Following up comment #39)
> 
> Here's another tryserver build of my patch for bug 708278:
> http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/smichaud@pobox.com-
> 011eb6a9ee19/try-macosx64/firefox-11.0a1.en-US.mac.dmg
> 
> I hope it will fix Vlad's crashes.
(In reply to comment #43)

Too bad.  Thanks for trying, though.
Given the data on this bug, and the tracking-fx9+, nominating this for tracking on Firefox 10 and 11. I doubt this can be fixed in time for Firefox 9 Release -- but lets see if we can get it fixed for Firefox 10.

Juan has agreed to ask Cheng if there are SUMO reports related to this issue so we can start to figure out how wide-spread it is.

Thanks Steven for your help so far with the try builds. Hopefully we can narrow this down.

Vlad, can you also do some regression testing? I don't see that we have attempted to reproduce this on:
 * an older version of Silverlight
 * an older version of Firefox
I talked to Cheng and he looked through the support feedback and it turns out this problem isn't widespread. It would be worrisome if this happened on Netflix, for example, which also uses Silverlight, but at this point this problem doesn't figure in beta support feedback.
Looks like Microsoft released Silverlight 5 today. Can you try retesting this with the update to see if the crash still reproduces?
All right, I tried this again with the instructions on comment #16, and I'm able to see the plugin crash as shown in comment #34. I think the key to reproducing this is clicking on a different video link while it is starting to load current one. 

In all cases I get a "No report available" message in the plugin crash dialog.

It's sort of easy to reproduce, but clicking on a different video or reloading the page allows me to continue browsing the videos.
By the way, I tried with Silverlight 5 and XP in comment #48.
I crashed today using trunk and Silverlight Version 5, and I did get two reports (browser and plugin) while playing some Bing Videos even though in the UI it said submission failed:

https://crash-stats.mozilla.com/report/index/bp-b9c7dd95-8fb6-414f-92bb-2a0d92111216
https://crash-stats.mozilla.com/report/index/b96e52b7-695c-4861-a3e2-61d182111216

Using Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:11.0a1) Gecko/20111216 Firefox/11.0a1 and Silverlight Version: 5.0.61118.0
https://crash-stats.mozilla.com/report/list?signature=hang%20|%20_chkstk and https://crash-stats.mozilla.com/report/list?signature=hang%20|%20kernelbase.dll@0x10db are your signatures and the latter seems to be pretty common on 11.0a1, but apparently on no other version. The former only happened once on 11.0a1 and once on 9.0b5.
Firefox crashed:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0) Gecko/20100101 Firefox/9.0RC

This are the ID's:
bp-5ead2e2c-bd2d-4fe8-bed7-9c3b62111219
bp-479d2322-064f-403b-9585-ce1992111219
bp-a13b3dd0-8110-4a7b-bef5-3823f2111219

The silverlight version is: 5.0.61118.0
Vlad, as you probably realize, your stacks are basically useless:
They're either corrupt, or all but the top one or two lines are
missing.

It might help to get Apple crash stacks for a few of your crashes.
But for that you'll need to be able to do a build with Breakpad
disabled and symbols not stripped, and test with that.  Are you up for
that?

Basic build instructions are here:
https://developer.mozilla.org/En/Developer_Guide/Build_Instructions

To disable Breakpad, you'll need to add the following line to your
mozconfig file:

ac_add_options --disable-crashreporter

Here's a mozconfig file that should give you what we need:

export CFLAGS="-gdwarf-2"
export CXXFLAGS="-gdwarf-2"
. $topsrcdir/browser/config/mozconfig
. $topsrcdir/build/macosx/universal/mozconfig
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/obj-firefox
mk_add_options MOZ_MAKE_FLAGS=-j4
mk_add_options AUTOCONF=autoconf213
ac_add_options --enable-application=browser
ac_add_options --enable-tests
ac_add_options --disable-strip
ac_add_options --disable-install-strip
ac_add_options --disable-crashreporter
ac_add_options --disable-optimize
ac_add_options --disable-debug
# For NSS symbols
export MOZ_DEBUG_SYMBOLS=1
ac_add_options --enable-debug-symbols="-gdwarf-2"
I've now done a build myself, following my own instructions from
comment #53.

I've found I can crash with it pretty easily using the URL from
comment #0 (http://www.bing.com/videos/browse) and the STR from
comment #16.  As Juan mentioned in comment #48, it helps to click on
another video just as the previous one is starting to load.  I pick
from among the thumbnails in the box to the right of the box where the
videos actually play.  On average I need to click on 7-8 videos before
the cursor beachballs.  Sometimes the apparent hang resolves itself
without a crash, but usually Silverlight crashes.

In 64-bit mode (the default) it's Silverlight's plugin-container
process that crashes.  In 32-bit mode (where Silverlight runs
in-process) the whole browser crashes.

I've been testing with the current version of Silverlight
(5.0.61118.0) on OS X 10.6.8.

I find I'm unable to crash Safari, Chrome or Opera (current versions)
using the STR described above.  And Firefox still crashes when I set
its user-agent string to Safari's.  So presumably we're doing
something to tick Silverlight off ... though whatever this is may not
be a bug.

It would be *very* helpful if we could find URLs that allow us to
switch between (say) Flash and QuickTime media as easily as this bug's
URL allows us to switch between Silverlight media.

(By the way, Silverlight *does* pay attention to the browser's
user-agent string.  And it at least used to run in different modes in
nightlies and releases -- unless you set general.useragent.override to
a release's user-agent string.)
Here's one of my Apple crashlogs -- representative of the
plugin-container crashes I've seen.

Apple's crashreporter UI doesn't appear for a plugin-container crash
(as it does for a crash in the browser).  But a crash log does get
written to ~/Library/Logs/DiagnosticReports/.

Both this and the firefox-bin crash (which I'll post next) happen deep
in Silverlight code, and seem to indicate a crash in a Silverlight C++
exception handler (__cxa_throw).  It's not at all clear why these
crashes should happen in Firefox but not in other browsers.

And a quirk of Silverlight's makes it particularly difficult to debug
problems with it -- Silverlight won't run in gdb!!  (If you try to run
Silverlight in gdb, gdb will crash soon after it hits your first
breakpoint.)
Vlad, I've noticed that Apple crash reports will sometimes get written to ~/Library/Logs/DiagnosticReports/ even when Breakpad isn't disabled.  The next time you reproduce this bug's crash, please check there for a corresponding Apple crash report.
Hi guys.
Firefox crashed again using the steps from previous comments:
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0) Gecko/20100101 Firefox/10.0 beta 2

I've attached a file with the MacOS X crash.
This is the report ID: bp-b98f1d7d-cf55-4eaf-87af-503d72111230
Hey Steven - sending this over to you since you're leading the engineering investigation. We're trying to make sure that all bugs tracked for Firefox 10 are assigned. Thanks!
Assignee: nobody → smichaud
(In reply to comment #59)

OK.  But it's pretty unlikely we'll be able to fix (or work around) this bug, since it's at least partly a Silverlight bug.

(In reply to comment #58)

Thanks, Vlad, for the Apple crash report.  It shows the same crash in __cxa_throw that I've been seeing.

But in the future *please* attach similar documents as text files -- not RTF files or some other binary format.
Severity: normal → critical
I was not able to reproduce this today on Windows 7 64-bit with a new profile. I did notice that Microsoft now offers a 64-bit version of Silverlight 5 by default now. I don't think they were doing this before so I suggest whomever was able to reproduce this earlier to please try with this plugin.
I could not reproduce the Silverlight crash using Firefox 11 beta 4 on Win 7 32-bit as described in Comment 16.

Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0
Vlad, can you please try to reproduce this in Firefox 11.0b5 using Silverlight 5 64-bit?
I have tried to reproduce with Silverlight Plug-in 5.0.61118.0 and the results are as follows:

- Silverlight Plug-in v5 64bit on Win 7 64bit : Silverlight doesn't crash but the video screen is grey (no video is playing)
- Silverlight Plug-in v5 32bit on Win 7 32bit : Silverlight is crashing and also the video screen is grey (no video is playing)
- Silverlight Plug-in v5 on MacOS X 10.7.3 : Firefox crashes after 3-4 videos

What I've noticed is that when the commercials are starting, Silverlight isn't crashing, this happened more on Windows 7.
Where is it crashing most? and how often? We should focus our investigation on that.
Can we get a Silverlight developer involved here?

This is almost certainly a Silverlight bug.  And (at least on the Mac) Silverlight makes it particularly difficult to debug this by preventing us from using gdb (see comment #55).
(In reply to comment #65)

From comments to date, it appears to be easiest to crash on OS X.  (Though please tell us if I'm wrong, Vlad.)

So we should first try to find a regression range on OS X.  I strongly suspect that the key factor here will be the Silverlight plugin version, and not the FF version.  But we can only be sure by testing.

I'm not going to have time to do this myself -- at least not for the next few weeks.  So others will need to do it.
(In reply to Steven Michaud from comment #66)
> Can we get a Silverlight developer involved here?
> 
> This is almost certainly a Silverlight bug.  And (at least on the Mac)
> Silverlight makes it particularly difficult to debug this by preventing us
> from using gdb (see comment #55).

I'm reaching out to Kev about getting a contact at MS/Silverlight.
Whiteboard: [qa+] → [qa+] STR in comment #16
I couldn't reproduce this issue on Mac OS 10.8 and Windows 7 x64 on FF 19b2 and Latest Nightly (2013/01/16) following steps from Comment 0 and info from Comment 16
Not able to reproduce on FF 20.b1 on Mac OS 10.6 and Windows 7 x64 and Ubuntu 12.04 x86:

Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:20.0) Gecko/20100101 Firefox/20.0 (20130220104816)

Based on this investigation and on Comment 69, marking this as Resolved WFM. If anyone can still reproduce this issue please reopen it.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.