crash in js::ExecuteRegExp

RESOLVED DUPLICATE of bug 763864

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 763864
7 years ago
6 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

({crash})

Trunk
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile-crash][native-crash], crash signature)

This bug was filed from the Socorro interface and is 
report bp-73e24777-7483-45cf-97ac-675352111108 .
============================================================= 
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	libicudata.so 	libicudata.so@0x11c 	
1 	libxul.so 	js::ExecuteRegExp 	js/src/builtin/RegExp.cpp:135
2 	libxul.so 	DoMatch 	js/src/jsstr.cpp:1490
3 	libxul.so 	js::str_replace 	js/src/jsstr.cpp:2066
4 	libxul.so 	js::InvokeKernel 	js/src/jscntxtinlines.h:297
5 	libxul.so 	js::Interpret 	js/src/jsinterp.cpp:3948
6 	libxul.so 	js::RunScript 	js/src/jsinterp.cpp:584
7 	libxul.so 	js::Invoke 	js/src/jsinterp.cpp:647
8 	libxul.so 	JS_CallFunctionValue 	js/src/jsapi.cpp:5168
9 	libxul.so 	nsXPCWrappedJSClass::CallMethod 	js/xpconnect/src/XPCWrappedJSClass.cpp:1533
10 	libxul.so 	nsXPCWrappedJS::CallMethod 	js/xpconnect/src/XPCWrappedJS.cpp:553
11 	libxul.so 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/unix/xptcstubs_arm.cpp:131
12 	libxul.so 	libxul.so@0x96340b 	
13 	libxul.so 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/unix/xptcinvoke_arm.cpp:194
14 	libxul.so 	xptiInterfaceEntry::GetEntryForParam 	xpcom/reflect/xptinfo/src/xptiInterfaceInfo.cpp:327
15 		@0x4d943abe 	
16 	libxul.so 	XPCWrappedNative::CallMethod 	js/xpconnect/src/XPCWrappedNative.cpp:2907
17 	libxul.so 	XPC_WN_CallMethod 	js/xpconnect/src/XPCWrappedNativeJSOps.cpp:1554
18 	libxul.so 	js::InvokeKernel 	js/src/jscntxtinlines.h:297
19 	libxul.so 	js::Interpret 	js/src/jsinterp.cpp:3948
20 	libxul.so 	js::RunScript 	js/src/jsinterp.cpp:584
21 	libxul.so 	js::Invoke 	js/src/jsinterp.cpp:647
22 	libxul.so 	JS_CallFunctionValue 	js/src/jsapi.cpp:5168
23 	libxul.so 	nsXPCWrappedJSClass::CallMethod 	js/xpconnect/src/XPCWrappedJSClass.cpp:1533
24 	libxul.so 	nsXPCWrappedJS::CallMethod 	js/xpconnect/src/XPCWrappedJS.cpp:553
25 	libxul.so 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/unix/xptcstubs_arm.cpp:131
26 	libxul.so 	libxul.so@0x96340b 	
27 	libxul.so 	nsTimerImpl::Fire 	xpcom/threads/nsTimerImpl.cpp:428
28 		@0xffffffff 	
29 	libxul.so 	nsTimerEvent::Run 	xpcom/threads/nsTimerImpl.cpp:521
30 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:631
31 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:245
32 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:110
33 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
34 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
35 	libxul.so 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:189
36 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:228
37 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3551
38 	libxul.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	toolkit/xre/nsAndroidStartup.cpp:132
39 	libmozutils.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	other-licenses/android/APKOpen.cpp:232
40 	libdvm.so 	dvmPlatformInvoke 	
41 	libdvm.so 	dvmCallJNIMethod_general 	
42 	libdvm.so 	dvmResolveNativeMethod 	
43 	libdvm.so 	dvmAsmSisterStart 	
44 	libdvm.so 	dvmMterpStd 	
45 	libdvm.so 	dvmInterpret 	
46 	libdvm.so 	dvmCallMethodV 	
47 	libdvm.so 	dvmCallMethod 	
48 	libdvm.so 	dvmAttachCurrentThread 	
49 	libc.so 	__thread_entry 	
50 	libc.so 	pthread_create 	

App Note : 
samsung GT-I9000
Samsung/GT-I9000/GT-I9000/GT-I9000:2.1-update1/ECLAIR/I9000XXJF3:user/release-keys

More of the same: 
https://crash-stats.mozilla.com/report/list?range_value=7&range_unit=days&date=2011-11-09&signature=libicudata.so%400x11c&version=Fennec%3A10.0a1
Crash Signature: [@ libicudata.so@0x11c | js::ExecuteRegExp ] [@ libicudata.so@0x11c] → [@ libicudata.so@0x11c | js::ExecuteRegExp ] [@ libicudata.so@0x11c] [@ @0x0 | js::ExecuteRegExp ]
Crash Signature: [@ libicudata.so@0x11c | js::ExecuteRegExp ] [@ libicudata.so@0x11c] [@ @0x0 | js::ExecuteRegExp ] → [@ libicudata.so@0x11c | js::ExecuteRegExp ] [@ libicudata.so@0x11c] [@ @0x0 | js::ExecuteRegExp ] [@ js::ExecuteRegExp ]
Crash Signature: [@ libicudata.so@0x11c | js::ExecuteRegExp ] [@ libicudata.so@0x11c] [@ @0x0 | js::ExecuteRegExp ] [@ js::ExecuteRegExp ] → [@ libicudata.so@0x11c | js::ExecuteRegExp ] [@ libicudata.so@0x11c] [@ @0x0 | js::ExecuteRegExp ] [@ js::ExecuteRegExp ] [@ @0x0 | libicudata.so@0x6 ] [@ @0x0 | libicudata.so@0x6 | js::ExecuteRegExp]

Updated

6 years ago
Summary: crash [@ libicudata.so@0x11c | js::ExecuteRegExp ] → crash in js::ExecuteRegExp
Whiteboard: [mobile-crash] → [mobile-crash][native-crash]

Updated

6 years ago
Crash Signature: [@ libicudata.so@0x11c | js::ExecuteRegExp ] [@ libicudata.so@0x11c] [@ @0x0 | js::ExecuteRegExp ] [@ js::ExecuteRegExp ] [@ @0x0 | libicudata.so@0x6 ] [@ @0x0 | libicudata.so@0x6 | js::ExecuteRegExp] → [@ libicudata.so@0x11c | js::ExecuteRegExp ] [@ libicudata.so@0x11c] [@ @0x0 | js::ExecuteRegExp ] [@ js::ExecuteRegExp ] [@ @0x0 | libicudata.so@0x6 ] [@ @0x0 | libicudata.so@0x6 | js::ExecuteRegExp] [@ js::ExecuteRegExp(JSContext* js::RegExpStati…
Version: 10 Branch → Trunk

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 763864
You need to log in before you can comment on or make changes to this bug.