Last Comment Bug 701584 - Mini-abstract some offsetofs noted in the initial patch for bug 699185
: Mini-abstract some offsetofs noted in the initial patch for bug 699185
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- minor (vote)
: mozilla11
Assigned To: Jeff Walden [:Waldo] (remove +bmo to email)
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-10 16:46 PST by Jeff Walden [:Waldo] (remove +bmo to email)
Modified: 2011-11-11 02:25 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (7.68 KB, patch)
2011-11-10 16:46 PST, Jeff Walden [:Waldo] (remove +bmo to email)
cdleary: review+
Details | Diff | Splinter Review

Description Jeff Walden [:Waldo] (remove +bmo to email) 2011-11-10 16:46:40 PST
Created attachment 573702 [details] [diff] [review]
Patch

Style for deep offsetofs in classes seems to be heading toward static inline methods that return them.  Continue this trend in a few more places.

Naming the JSFunction::U::n struct isn't really necessary, but it makes it consistent with Scripted right next to it.
Comment 1 Jeff Walden [:Waldo] (remove +bmo to email) 2011-11-10 22:29:34 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/f4183f93f844
Comment 2 Marco Bonardo [::mak] 2011-11-11 02:25:27 PST
https://hg.mozilla.org/mozilla-central/rev/f4183f93f844

Note You need to log in before you can comment on or make changes to this bug.