Closed Bug 701617 Opened 13 years ago Closed 13 years ago

document.write() after alert crashes fennec 11

Categories

(Core :: Graphics, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 694964
mozilla11

People

(Reporter: jhammink, Assigned: jhammink)

Details

(Keywords: crash)

Attachments

(1 file)

If you run the page at http://people.mozilla.com/~jhammink/webapi_test_pages/BatteryCrashv2.html  on the latest Fennec Nightly, it will crash after I "ok" the alert and JS attempts to execute document.write() function

both the crashing script and dump are attached here.
Got a link to a crash log?
OS: Mac OS X → All
Hardware: x86 → All
(No idea if this is parsing related or JS or Fennec specific)
Link to the crash log is here.

http://pastebin.mozilla.org/1380355
OS: All → Android
Hardware: All → ARM
I will try this out with latest nightly fennec 111111 (where latest battery API changes should be implemented) to see if it's still crashing.
Most of that log is after the actual process death, and there's not enough log before the death to see what the problem is. See line 12 (11-11 11:38:41.362: I/ActivityManager(291): Process org.mozilla.fennec_jlebar (pid 6142) has died.)
still crashing on latest, nightly fennec
It's not possible to get more log because generating the original popup from the testpage involves connecting/disconnecting cable (changing battery charging state).

This is the log that is generated after state changed, and user clicks OK to the dialog.  It's after that when the crash actually happens.
I made a second log from alogcat running directly on the device:

http://pastebin.mozilla.org/1380357

Does this have all the necessary information?
Is it not possible to get a stack trace from Android?
found this on about crashes on my Asus Transformer running 3.2

https://crash-stats.mozilla.com/report/index/bp-9613bcf8-0d9f-48f1-a3de-5fda72111111

Is this what you need?
(In reply to John Hammink from comment #10)
> found this on about crashes on my Asus Transformer running 3.2
> 
> https://crash-stats.mozilla.com/report/index/bp-9613bcf8-0d9f-48f1-a3de-
> 5fda72111111
> 
> Is this what you need?

If you can confirm that this is the precise report that's generated by the crash, yes. If you can reproduce it and check that the time on the most recent report matches the time of the crash, that would be great.
These are the crashes, confirmed.
Keywords: crash
Component: DOM → Graphics
QA Contact: general → thebes
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: