Last Comment Bug 701627 - slashdot.org doesn't fire MozScrolledAreaChanged events as the page gets bigger while loading
: slashdot.org doesn't fire MozScrolledAreaChanged events as the page gets bigg...
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Mac OS X
: P1 normal (vote)
: ---
Assigned To: Doug Turner (:dougt)
:
Mentors:
http://slashdot.org/
Depends on:
Blocks: native_droid_panning
  Show dependency treegraph
 
Reported: 2011-11-10 22:37 PST by Patrick Walton (:pcwalton)
Modified: 2012-01-09 11:21 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
patch v.1 (1.71 KB, patch)
2011-11-28 21:18 PST, Doug Turner (:dougt)
no flags Details | Diff | Review
patch v.1 (1.60 KB, patch)
2011-11-28 21:22 PST, Doug Turner (:dougt)
mark.finkle: review+
Details | Diff | Review

Description Patrick Walton (:pcwalton) 2011-11-10 22:37:40 PST
Because we resize the page only upon receiving MozScrolledAreaChanged, we end up with a page much smaller than it should be. (How did XUL Fennec do this? It must have had the same issue...)
Comment 1 Doug Turner (:dougt) 2011-11-14 10:26:36 PST
I think we had similar problems with the xul fennec.  whenever we did complete loading, we asked "how big are you".  A workaround, yes.
Comment 2 Doug Turner (:dougt) 2011-11-28 21:18:16 PST
Created attachment 577481 [details] [diff] [review]
patch v.1
Comment 3 Doug Turner (:dougt) 2011-11-28 21:22:00 PST
Created attachment 577483 [details] [diff] [review]
patch v.1
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-28 21:23:58 PST
Comment on attachment 577483 [details] [diff] [review]
patch v.1


>diff --git a/mobile/android/chrome/content/browser.js b/mobile/android/chrome/content/browser.js
>   get viewport() {

>-    let doc = this.browser.contentDocument.documentElement;
>+    let cdoc = this.browser.contentDocument;

Call me crazy, but I like "doc" better than "cdoc"
Comment 5 Doug Turner (:dougt) 2011-11-28 21:42:15 PST
http://hg.mozilla.org/projects/birch/rev/82f3392976b4

Note You need to log in before you can comment on or make changes to this bug.