transform 3D don't work in transform 3D element

RESOLVED FIXED in mozilla11

Status

()

Core
Layout: View Rendering
RESOLVED FIXED
6 years ago
a year ago

People

(Reporter: Zéfling, Assigned: mattwoodrow)

Tracking

(Depends on: 1 bug)

Trunk
mozilla11
x86_64
Windows Server 2003
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox10-)

Details

(Whiteboard: [mozfr-community])

Attachments

(6 attachments, 1 obsolete attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.2; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

The webkit demonstration with transform-style: preserve-3d + transform: rotateY  and children with transform: translateZ don't work correctly. 3D effects is not apply on children.

http://ikilote.net/Programmation/CSS/Test/transform-style.htm
Not a CSSOM issue...

Matt, could you take a look at this?
Status: UNCONFIRMED → NEW
tracking-firefox10: --- → ?
Component: DOM: CSS Object Model → Layout: View Rendering
Ever confirmed: true
QA Contact: style-system → layout.view-rendering
Version: unspecified → Trunk
(Assignee)

Updated

6 years ago
Assignee: nobody → matt.woodrow
(FWIW, I get invalidation artifacts on this bug's testcase -- I filed bug 702149 on that.)
(Assignee)

Comment 3

6 years ago
Created attachment 574503 [details] [diff] [review]
Make WrapPreserve3DList capable of walking through child display items for the same frame
Attachment #574503 - Flags: review?(roc)
(Assignee)

Comment 4

6 years ago
Created attachment 574505 [details] [diff] [review]
Include the preserve-3d parent content in preserve-3d sorting
Attachment #574505 - Flags: review?(roc)
(Assignee)

Updated

6 years ago
Attachment #574503 - Attachment is patch: true
(Assignee)

Comment 5

6 years ago
These patches fix the majority of the problems with this test case (including the visible effects of bug 702149), though it appears we are still calculating incorrect visible regions and are clipping the transformed objects at times.

We also appear to have a different interpretation of group opacity for preserve-3d objects here, I'll put this in an email to www-style to discuss this.
Attachment #574503 - Flags: review?(roc) → review+
Attachment #574505 - Flags: review?(roc) → review+
Need reftests...
(Assignee)

Comment 7

6 years ago
Created attachment 574525 [details] [diff] [review]
Add tests
Attachment #574525 - Flags: review?(roc)
Attachment #574525 - Flags: review?(roc) → review+
(Assignee)

Comment 8

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/75869e1354d0
https://hg.mozilla.org/integration/mozilla-inbound/rev/17c9363d801a
https://hg.mozilla.org/integration/mozilla-inbound/rev/bb6ef2d824a8
https://hg.mozilla.org/mozilla-central/rev/75869e1354d0
https://hg.mozilla.org/mozilla-central/rev/17c9363d801a
https://hg.mozilla.org/mozilla-central/rev/bb6ef2d824a8
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla11
(Reporter)

Comment 10

6 years ago
Created attachment 575513 [details]
Gecko (Nightly) & Webkit (Iron) render

It's really resolved ? The result is strange in Gecko...
What release channel is your nightly build from? This was fixed only on mozilla-central (what will become Firefox 11). This will not work on nightlies from the Aurora/Beta/Release channels.
Attachment #575513 - Attachment mime type: application/octet-stream → video/webm
(Reporter)

Comment 12

6 years ago
I'm user agent is :
Mozilla/5.0 (Windows NT 5.2; WOW64; rv:11.0a1) Gecko/20111118 Firefox/11.0a1

Is it not the last ?
Yes, that's the correct build to be testing. Thanks for confirming.
(Assignee)

Updated

6 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
[Triage Comment]
This would not block shipping FF10, but we'd consider taking a low risk patch for Aurora if nominated.
tracking-firefox10: ? → -
(Assignee)

Comment 15

6 years ago
Can you post the contents of your about:support please?
(Reporter)

Comment 16

6 years ago
Created attachment 578324 [details]
about:support
(Reporter)

Comment 17

6 years ago
Created attachment 578335 [details]
With new profile

Oh! With a new profile it's better, but the render is cut.
Attachment #575513 - Attachment is obsolete: true
(Reporter)

Updated

6 years ago
Attachment #578335 - Attachment description: With new profil → With new profile
Attachment #578335 - Attachment mime type: application/octet-stream → video/webm
(Reporter)

Updated

6 years ago
Attachment #575513 - Attachment is obsolete: false
(Assignee)

Updated

6 years ago
Depends on: 707563
(Assignee)

Comment 18

6 years ago
Filed bug 707563 for the remaining Layers bug here.
(Reporter)

Comment 19

6 years ago
Created attachment 580961 [details]
Gecko (Nightly) & Webkit (Iron) render

With bug 707563, the result is better, but the text is distorted. Opacity is strange, as if it were applied at all evenly.
Attachment #575513 - Attachment is obsolete: true
(Reporter)

Updated

6 years ago
Attachment #580961 - Attachment mime type: application/octet-stream → video/webm
(Reporter)

Comment 20

6 years ago
Is this bug does not okay ? For the opacity, it seems that it is not a bug. I think this bug may be closed. The opacity is same for all element in flat mode and perserve-3D. It's not specify in the daft of the W3C. 

Can I close this bug ?

Updated

6 years ago
Depends on: 730166
(In reply to Célian VEYSSIÈRE from comment #20)
> Can I close this bug ?

Let's see if Matt agrees before closing this bug. Thanks.
(Assignee)

Updated

6 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED

Updated

6 years ago
Depends on: 735178

Updated

5 years ago
Depends on: 810685
(Reporter)

Updated

a year ago
Whiteboard: [mozfr-community]
You need to log in before you can comment on or make changes to this bug.