Last Comment Bug 701716 - navigator.vibrate Android backend is missing an AutoLocalJNIFrame.
: navigator.vibrate Android backend is missing an AutoLocalJNIFrame.
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: mozilla11
Assigned To: Justin Lebar (not reading bugmail)
:
:
Mentors:
Depends on:
Blocks: 679966
  Show dependency treegraph
 
Reported: 2011-11-11 07:57 PST by Justin Lebar (not reading bugmail)
Modified: 2012-02-01 13:57 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
fixed


Attachments
Patch v1 (985 bytes, patch)
2011-11-11 07:58 PST, Justin Lebar (not reading bugmail)
mwu.code: review+
Details | Diff | Splinter Review

Description Justin Lebar (not reading bugmail) 2011-11-11 07:57:53 PST
Filing this as a separate bug from bug 679966 since it requires us to modify code which is currently in the tree.

The following code causes Fennec to crash

while(true) {
  navigator.mozVibrate([100, 100]);
}

W/dalvikvm(16350): ReferenceTable overflow (max=512)
W/dalvikvm(16350): Last 10 entries in JNI local reference table:
W/dalvikvm(16350):   502: 0x40612028 cls=[J (44 bytes)
W/dalvikvm(16350):   503: 0x40612360 cls=[J (44 bytes)
W/dalvikvm(16350):   504: 0x40612698 cls=[J (44 bytes)
... and so on

The problem is a missing AutoLocalJNIFrame in AndroidBridge.
Comment 1 Justin Lebar (not reading bugmail) 2011-11-11 07:58:53 PST
Created attachment 573810 [details] [diff] [review]
Patch v1

I'll add a test to the DOM implementation in bug 679966.
Comment 2 Justin Lebar (not reading bugmail) 2011-11-11 08:03:49 PST
Comment on attachment 573810 [details] [diff] [review]
Patch v1

Strangely enough, I had do do a full clobber for this change to have any effect.
Comment 3 Justin Lebar (not reading bugmail) 2011-11-11 08:08:39 PST
This should land in Aurora unless we back out bug 679966.  I'd prefer to back it out and have an outstanding backout request in the bug.
Comment 4 Justin Lebar (not reading bugmail) 2011-11-11 08:39:24 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/f3411e7e4bc1
Comment 5 Ed Morley [:emorley] 2011-11-12 04:55:25 PST
https://hg.mozilla.org/mozilla-central/rev/f3411e7e4bc1

Note You need to log in before you can comment on or make changes to this bug.