Last Comment Bug 701730 - StrictMode: Disk Read Violation when opening the awesomebar (rememberLastScreen)
: StrictMode: Disk Read Violation when opening the awesomebar (rememberLastScreen)
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P1 normal (vote)
: ---
Assigned To: Brad Lassey [:blassey] (use needinfo?)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-11 08:29 PST by Mark Finkle (:mfinkle) (use needinfo?)
Modified: 2012-03-06 06:26 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments

Description Mark Finkle (:mfinkle) (use needinfo?) 2011-11-11 08:29:14 PST
I see 3 in logcat:

StrictMode policy violation; ~duration=356 ms: android.os.StrictMode$StrictModeDiskReadViolation: policy=23 violation=2

StrictMode policy violation; ~duration=345 ms: android.os.StrictMode$StrictModeDiskWriteViolation: policy=23 violation=1

StrictMode policy violation; ~duration=317 ms: android.os.StrictMode$StrictModeDiskWriteViolation: policy=23 violation=1

All are triggered from:

D/StrictMode(22760): 	at android.app.ContextImpl$SharedPreferencesImpl$EditorImpl.commit(ContextImpl.java:3049)
D/StrictMode(22760): 	at org.mozilla.gecko.GeckoApp.rememberLastScreen(GeckoApp.java:515)
D/StrictMode(22760): 	at org.mozilla.gecko.GeckoApp.onPause(GeckoApp.java:1229)
D/StrictMode(22760): 	at android.app.Activity.performPause(Activity.java:3851)
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-20 19:55:40 PST
fixed by bug 703057
Comment 2 David Burns :automatedtester 2011-11-21 14:27:29 PST
I am getting this issue with a build that I did a couple hours ago that was running 
build from http://hg.mozilla.org/projects/birch/rev/41b63b2b6420.

Logcat below

11-21 22:10:38.176: D/StrictMode(2737): StrictMode policy violation; ~duration=1 ms: android.os.StrictMode$StrictModeDiskReadViolation: policy=23 violation=2
11-21 22:10:38.176: D/StrictMode(2737): 	at android.os.StrictMode$AndroidBlockGuardPolicy.onReadFromDisk(StrictMode.java:1067)
11-21 22:10:38.176: D/StrictMode(2737): 	at android.os.StrictMode.noteDiskRead(StrictMode.java:1803)
11-21 22:10:38.176: D/StrictMode(2737): 	at android.os.FileUtils.getFileStatus(FileUtils.java:80)
11-21 22:10:38.176: D/StrictMode(2737): 	at android.app.SharedPreferencesImpl.writeToFile(SharedPreferencesImpl.java:579)
11-21 22:10:38.176: D/StrictMode(2737): 	at android.app.SharedPreferencesImpl.access$800(SharedPreferencesImpl.java:47)
11-21 22:10:38.176: D/StrictMode(2737): 	at android.app.SharedPreferencesImpl$2.run(SharedPreferencesImpl.java:489)
11-21 22:10:38.176: D/StrictMode(2737): 	at android.app.SharedPreferencesImpl.enqueueDiskWrite(SharedPreferencesImpl.java:510)
11-21 22:10:38.176: D/StrictMode(2737): 	at android.app.SharedPreferencesImpl.access$100(SharedPreferencesImpl.java:47)
11-21 22:10:38.176: D/StrictMode(2737): 	at android.app.SharedPreferencesImpl$EditorImpl.commit(SharedPreferencesImpl.java:432)
11-21 22:10:38.176: D/StrictMode(2737): 	at org.mozilla.gecko.GeckoApp.rememberLastScreen(GeckoApp.java:542)
11-21 22:10:38.176: D/StrictMode(2737): 	at org.mozilla.gecko.GeckoApp.access$700(GeckoApp.java:89)
11-21 22:10:38.176: D/StrictMode(2737): 	at org.mozilla.gecko.GeckoApp$26.run(GeckoApp.java:1346)
11-21 22:10:38.176: D/StrictMode(2737): 	at android.os.Handler.handleCallback(Handler.java:587)
11-21 22:10:38.176: D/StrictMode(2737): 	at android.os.Handler.dispatchMessage(Handler.java:92)
11-21 22:10:38.176: D/StrictMode(2737): 	at android.os.Looper.loop(Looper.java:132)
11-21 22:10:38.176: D/StrictMode(2737): 	at org.mozilla.gecko.GeckoApp$23.run(GeckoApp.java:1205)
11-21 22:10:38.176: D/StrictMode(2737): 	at android.os.Handler.handleCallback(Handler.java:587)
11-21 22:10:38.176: D/StrictMode(2737): 	at android.os.Handler.dispatchMessage(Handler.java:92)
11-21 22:10:38.176: D/StrictMode(2737): 	at android.os.Looper.loop(Looper.java:132)
11-21 22:10:38.176: D/StrictMode(2737): 	at android.app.ActivityThread.main(ActivityThread.java:4123)
11-21 22:10:38.176: D/StrictMode(2737): 	at java.lang.reflect.Method.invokeNative(Native Method)
11-21 22:10:38.176: D/StrictMode(2737): 	at java.lang.reflect.Method.invoke(Method.java:491)
11-21 22:10:38.176: D/StrictMode(2737): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:841)
11-21 22:10:38.176: D/StrictMode(2737): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:599)
11-21 22:10:38.176: D/StrictMode(2737): 	at dalvik.system.NativeStart.main(Native Method)
Comment 3 Brad Lassey [:blassey] (use needinfo?) 2011-11-21 14:32:14 PST
that's a different bug, please file it
Comment 4 Catalin Suciu [:csuciu] 2012-03-06 06:26:39 PST
Cannot reproduce this errors on: 
Nightly 13.0a1(2012-03-04)
Device: Samsung Galaxy S2
OS: Android 2.3.4

Note You need to log in before you can comment on or make changes to this bug.