figure out what to do with the n900s

RESOLVED FIXED

Status

Release Engineering
Other
RESOLVED FIXED
6 years ago
9 months ago

People

(Reporter: aki, Assigned: hlangi)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [maemo][n900s])

(Reporter)

Description

6 years ago
These are no longer running in production.
They're still useful for someone who wants to reimage them and maintain them.

Digipengi knows of a company that's willing to purchase them from us, but that may involve red tape.  Community members or projects may want them as well.

Comment 1

6 years ago
(In reply to Aki Sasaki [:aki] from comment #0)
> These are no longer running in production.
> They're still useful for someone who wants to reimage them and maintain them.
> 
> Digipengi knows of a company that's willing to purchase them from us, but
> that may involve red tape.  Community members or projects may want them as
> well.

I know many are eager to take baseball bats to these things, but if the company in question is even remotely aligned with our interests, I think it makes sense to flat-out donate the n900s and see them get used. 

I guess the question becomes: how much red tape?
(Reporter)

Comment 2

6 years ago
http://www.pwnieexpress.com/

This often becomes a legal or CFO level red tape issue, tied to IRS paperwork and such.  Having said that, I haven't specifically asked about donating or selling Mozilla equipment; I'm basing this off of other attempts to donate or sell equipment at other companies.
I know a company that would love these now I know it would have to go through legal about selling but possibly "donating" them?
opps I should read fully before posting lol.
I would like 2 of these devices for my personal use if possible though.
(In reply to Chris Cooper [:coop] from comment #1)
> (In reply to Aki Sasaki [:aki] from comment #0)
> > These are no longer running in production.
> > They're still useful for someone who wants to reimage them and maintain them.
> > 
> > Digipengi knows of a company that's willing to purchase them from us, but
> > that may involve red tape.  Community members or projects may want them as
> > well.
> 
> I know many are eager to take baseball bats to these things, but if the
> company in question is even remotely aligned with our interests, I think it
> makes sense to flat-out donate the n900s and see them get used. 

mfinkle, blassey: can you let me know offline the names of any external companies you think might be interested in these n900s for ongoing mozilla/firefox development work?

Comment 7

6 years ago
I guess people working with the "Nemo mobile" project might be interested in some N900s. Maybe someone there is also interested in continuing Firefox builds through their OBS infrastructure, for maemo and nemo.
I'd grab a few for personal use if possible.
I'd like to request 4 of these devices and a test jig for my own projects

Updated

6 years ago
Depends on: 705734
If these devices will be given to people I would like to grab one of those for personal use and projects involving Linux and mobility.

Comment 11

6 years ago
I'd like to request 1 of these devices for Nemomobile and othe open source project
I'd like to request also 1 of these devices for personal use and Linux related projects.
I'd like to request one device for personal use as well, if possible.

Comment 14

6 years ago
Bespoke I/O could use one or two, if that's possible.

Comment 15

6 years ago
I am working on Mer adaptations and could use a n900 and a test jig if available

Comment 16

6 years ago
I'd like to request 1 of these devices for develop "Smile to UnLock" for Nemomobile and othe open source project.

Comment 17

5 years ago
I maintain Gentoo for N900; it would be nice to have a spare for not having to choose between usage and update/install (Gentoo compiles everything, which makes it unusable), and so the project doesn't just die when/if my USB port breaks off (a common problem with N900s). :)
<pileon> If there are any left, I'd love to use one of these for educational/personal use.

Comment 19

5 years ago
If it would be possible, I would like to request one for personal and school-related use.
To possibly head-off a spate of other "me toos" in this bug (and to avoid individuals getting their hopes up): we're trying to unload these n900s en masse if at all possible. 

While I understand the lure of free hardware, we'd like to avoid the logistical nightmare of shipping 1 or 2 units to 100s of different people.

Comment 21

5 years ago
I'm not sure there are many projects that could benefit from having a lot of these... perhaps a good route would be to find someone who is willing to take the lot and ship them out individually (or in pairs)?
(In reply to Luke-Jr from comment #21)
> I'm not sure there are many projects that could benefit from having a lot of
> these... perhaps a good route would be to find someone who is willing to
> take the lot and ship them out individually (or in pairs)?

hi LukeJr;

Yep, that "someone" is me right now. I'm using this bug to collect names of interested people, while I also work through details with legal and finance.

Comment 23

5 years ago
I'd also like to add that it would actually be convenient if I had a few more *extra* N900s to spare, as I'd like to test the highpass filter and torch safeties, but don't want to risk destroying my own device if it doesn't work :P

I don't know how many there are total here, though.

(without a working highpass filter, direct ALSA access to the speakers can blow them, and stock kernel also allows burning out the torch LED)
This is probably a stupid idea, and I'm not sure that the IRS would like this, but one person could take them all, and sell them somewhere (Like eBay), then give all the money, minus shipping costs, back to the foundation.

Comment 25

5 years ago
Proposing one possible group that could use several of those - Devaamo ry. It's a non-profit based in Tampere Finland. One form of activity we do is that we loan hackable devices to developers who need them. We already have some n900s donated by Nokia but could use some more. Devaamo is also in co-operation with the local hackerspace who would most certainly want to have a few those to do hw hacking with.

Of cource I have my own interest here as well being a mer/nemomobile contributor and could use a spare device :) - anyway I guess we could take ten-twenty of you if at all possible.

See Devaamo ry website (devaamo.fi) for more info and contact details.

Thanks,

timoph
(In reply to timop.harkonen from comment #25)
> Proposing one possible group that could use several of those - Devaamo ry.
> It's a non-profit based in Tampere Finland. One form of activity we do is

Sidenote, besides my Mozilla background I'm also a Devaamo board member.
I'll be both at FOSDEM next weekend and I'll be in Redwood Shores for ABS/ELC and the latter locagtion is around the corner of Mountain View. So if either would be convenient I'd be happy to help avoid shipping cost. (If a decision would happen that soon ofc.)

Comment 27

5 years ago
What is the current status of this project of finding new homes for Mozilla’s N900s?

I would appreciate having at least 1 more N900, especially because I already broke the USB port on my first N900.  Nokia USA replaced my first N900 under warranty but it was a huge hassle because I live in Canada but Nokia’s warranty is only for the USA:  you can read the beginning of my story here:

http://lists.openmoko.org/pipermail/community/2010-September/063052.html

As you can tell from this mailing list post, I used an Openmoko GTA02 (OpenMoko Neo FreeRunner) and was involved in the Openmoko community, especially the QtMoko distribution, before I switched from (primarily QtMoko on) the GTA02 to Maemo 5 on the N900.

I have been a Netscape and Mozilla fan, enthusiast, and user since the 1990s.  In terms of contributions to Mozilla software instead of the Mozilla community, I am (indirectly) responsible for the fixing of at least 2 long-standing bugs: bug 178506 and bug 269728 .  I did not actually fix the bugs myself, but I hired and paid programmers to fix the bugs.

Comment 28

5 years ago
(In reply to Brolin Empey from comment #27)
> What is the current status of this project of finding new homes for
> Mozilla’s N900s?

After 4 months and 1 week, I still do not have an answer to my simple question.  Even an answer of “I do not know.” would (probably) be better than no reply at all.
(Reporter)

Comment 29

5 years ago
I do not know.  Most likely not high on the priorities list.

Comment 30

5 years ago
My n900 is very near dead, I could use one or two (the USB port really is the most likely point of failure, and I experienced that while @nokia - where the fix was to pick up another device...).

I tend to lend out phones to Mozillans (my n8 is on loan). 

I'm near the Toronto office, but I'm sure I'll be near MV eventually (hopefully before my n900 stops working completely).
Since IT moved, these are now located in a box in one of the black cabinets in R2/D2/C3P0.
Product: mozilla.org → Release Engineering
Found in triage. hwine, can you followup here?
Assignee: john+bugzilla → hwine

Comment 33

3 years ago
I vaguely remember that John said some time ago that those old N900s are still lying around at Mozilla. Now, there's the Neo900 project going on - http://neo900.org/ - that wants to build renewed SoCs that can run in an N900 case, and from a short IRC discussion, they said they'd be surely interested in getting "a few dozen devices" (I told them I might know a source that has those, without revealing details of who and where).
The good thing is that they'd take all of the devices and they'd get to a good use. The downside is that apparently those guys are in the EU so the customs stuff may need to be figured out - but I guess it would be best to figure that out with those guys directly (and it would be only a single package).

What do you think?

[I recently emailed John about this but didn't get a reply, so re-stating this here.]

Comment 34

3 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #33)
> I vaguely remember that John said some time ago that those old N900s are
> still lying around at Mozilla. Now, there's the Neo900 project going on -
> http://neo900.org/ - that wants to build renewed SoCs that can run in an
> N900 case,

The Neo900 project does not build SoCs.  The hardware product (deliverable) of the Neo900 project is an upgraded mainboard for the Nokia N900.  The Neo900 mainboard is based on the GTA04, which is an upgraded mainboard for the Openmoko GTA02, which is marketed as the Openmoko Neo FreeRunner.

Comment 35

3 years ago
Yeah, s/SoCs/PCBs/
As Neo900 project wants to offer also complete devices, it needs the cases and display parts to put the new PCBs into them.

Comment 36

3 years ago
Yes, sorry for my lapse there, comment #35 explains it correctly. :)
These units are no longer used as part of the build farm so releng will get out of the decision loop.

If any staff member needs one for work use, please open a separate bug and we'll arrange shipping. (Those units would continue to be tracked in inventory.)

My understanding is that :dmoore coordinates all equipment donations, and that Mozilla policy requires donation to a valid US tax exempt organization. 

dmoore: is there a wiki with the procedure they would follow to request the donation?
Flags: needinfo?(dmoore)
(Assignee)

Comment 38

3 years ago
Anyone still interested in these devices? Will need a list of individuals/organizations for these to be donated to.

Comment 39

3 years ago
I could still use a spare(s).

Comment 40

3 years ago
I am still interested.

Comment 41

3 years ago
Well, in case comment 38 can be interpreted as "interest && personal usecase not necessarily related to Mozilla" then I wouldn't be unhappy about a spare either. :)

Comment 42

3 years ago
The Neo900 project is pretty surely still interested, and could take a number of them in bulk.
(Assignee)

Comment 43

3 years ago
(In reply to Robert Kaiser (:kairo@mozilla.com, slow reaction due to vacation backlog) from comment #42)
> The Neo900 project is pretty surely still interested, and could take a
> number of them in bulk.

We have a total of 84 devices, so just need to gather a list of the individual requests and get the rest donated to the Neo900 project.
(Assignee)

Comment 44

3 years ago
I was able to contact someone from the Neo900 project and they're highly interested in receiving a bulk of these devices. I plan on shipping them whatever is left over from the individual requests, which should be about 48 devices.

Here is a list of individuals that are interested and folks that still need to confirm:

Confirmed and need shipping info:

1. Luke-Jr comment 39
2. Chris comment 40
3. Andre Klapper comment 41

Will need the following folks to confirm by 8/31/14 if still interested:

1. John Ford [:jhford] comment 9 4x
2. Remus Pop (:RemusPop) comment 10
3. Nicola De Filippo comment 11
4. Trif Andrei-Alin[AlinT] comment 12
5. Mike Hoye comment 14
6. Emmanuel Grantello comment 16
7. Tanner Filip [:tanner] comment 18
8. Jan Bambach [:Jan] comment 19
9. timoph comment 25 20x Devaamo
10. Brolin Empey comment 27
11. timeless comment 30
Flags: needinfo?(trifandreialin)
Flags: needinfo?(timop.harkonen)
Flags: needinfo?(timeless)
Flags: needinfo?(tanner.sumo.bugs)
Flags: needinfo?(remus.pop)
Flags: needinfo?(nicola)
Flags: needinfo?(mhoye)
Flags: needinfo?(jhford)
Flags: needinfo?(jan)
Flags: needinfo?(emmanuelgranatello)
Flags: needinfo?(dmoore)
Flags: needinfo?(brolin)

Comment 45

3 years ago
I'm still interested. I can pick it up from the Toronto office.
Flags: needinfo?(timeless)

Comment 46

3 years ago
I am still interested.  Should I privately electronically mail you with my physical mail address?
Flags: needinfo?(brolin)

Comment 47

3 years ago
Still interested. Who do I email the shipping address to?
Flags: needinfo?(timop.harkonen)
(Assignee)

Comment 48

3 years ago
Please email me directly (hlangi@mozilla.com) with your shipping addresses and contact number.
I can do without.
Flags: needinfo?(tanner.sumo.bugs)
Please do not send any n900s to me.  I no longer want them.
Flags: needinfo?(jhford)
Thanks to :henry for taking this over!
Assignee: hwine → henry

Comment 52

3 years ago
Still interested, e-mail sent.
Flags: needinfo?(jan)

Comment 53

3 years ago
For the late ones and people who will discover this thread sometime in the future: 
We at Neo900 are going to use donated N900s mostly as development devices to be handed out to the community, therefore we'll happilly give them to developers who want to work on something even remotely related to Neo900. Just let us (Neo900) know if you need a N900 (for Firefox OS for N900/Neo900 maybe? :)) - those devices won't end up slaughtered to parts. Unless someone needs a board only and someone else just a case, that is ;)

Comment 54

3 years ago
Remus doesn't use that addreess anymore so he probably won't see the request.
Flags: needinfo?(remus.pop)
Still interested, but a "little" too late with the response.
Flags: needinfo?(trifandreialin)
:henry, is there anything left to do here or can we close the bug?
Flags: needinfo?(henry)
QA Contact: mshal
(Assignee)

Comment 57

9 months ago
Wow, this can be closed since have no more in stock. Sorry for not closing this out back in 2014.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Flags: needinfo?(henry)
Resolution: --- → FIXED
Thanks!
Flags: needinfo?(nicola)
Flags: needinfo?(mhoye)
Flags: needinfo?(emmanuelgranatello)
You need to log in before you can comment on or make changes to this bug.