No indication that Save as PDF is complete

RESOLVED DUPLICATE of bug 701797

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 701797
6 years ago
a year ago

People

(Reporter: lmandel, Assigned: madhava)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20111111])

After I click Save as PDF I see a notification that the PDF is downloading. I do not receive any notification or other link that allows me to easily view the PDF. Note that I have confirmed that the PDF has successfully been created by browsing to my downloads folder using Astro.

Steps to reproduce:
1. Open a page in nightly.
2. Click Save as PDF.
3. Confirm manually that the PDF has completed. No notification status has been shown.

Actual results:
No notification is shown when the PDF creation completes.

Expected results:
A notification should alert me that the PDF has been created and allow me to click on it to view the PDF.

Environment
HTC Desire
Android 2.2
Default Android behaviour is to utilize the drop/pull down notification tray;  toast alerts have such short duration and never receive focus for action. I see the status, "Download Complete" under the item of which I downloaded under Android 2.3.4 (Galaxy SII).
(In reply to Aaron Train [:aaronmt] from comment #1)
> Default Android behaviour is to utilize the drop/pull down notification
> tray;  toast alerts have such short duration and never receive focus for
> action. I see the status, "Download Complete" under the item of which I
> downloaded under Android 2.3.4 (Galaxy SII).

my HTC Desire HD (running 2.3.3) says under Notifications:

Downloads
Downloading: ...

but it never says "complete" or something similar. Also it takes me to Fennec when I click on this notification instead of opening the pdf. This behaviour is okay as long the pdf is downloading, but not when it finished.
(Assignee)

Comment 3

6 years ago
What, generally, are we doing about a download manager? There was talk of making use of the central downloads list. If we are, the "complete" message should take you there.
Assignee: nobody → madhava
Do we have "Download complete" for _any_ downloads? The system notification shows the PDF. Tempted to close this bug, or make a new bug for _all_ downloads.
I don't see any notification, system or otherwise, that the PDF download has completed. Put another way, after I click Save as PDF I don't know where to go to actually view the PDF.

Comment 6

6 years ago
(In reply to Mark Finkle (:mfinkle) from comment #4)
> Do we have "Download complete" for _any_ downloads? The system notification
> shows the PDF. Tempted to close this bug, or make a new bug for _all_
> downloads.

When downloading a normal PDF from the web, you get a download completed notification, and the download opens on completion, so I think this issue is specific to save as PDF.

Comment 7

6 years ago
I'm duping this to bug 701797, since the solution there (fixing download observer notifications) should solve this problem as well.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 701797
(In reply to Margaret Leibovic [:margaret] from comment #6)
> (In reply to Mark Finkle (:mfinkle) from comment #4)
> > Do we have "Download complete" for _any_ downloads? The system notification
> > shows the PDF. Tempted to close this bug, or make a new bug for _all_
> > downloads.
> 
> When downloading a normal PDF from the web, you get a download completed
> notification, and the download opens on completion, so I think this issue is
> specific to save as PDF.

Even when a webpage is saved as PDF, sometimes I get the notification that the PDF was saved (downloaded). When the completed notification is not triggered, if you close the app and then reopen it again and if you save any webpage as PDF, then the previous missing notifications (for completed downloads from previous sessions - before closing Fennec) are triggered.

Comment 9

6 years ago
(In reply to Cristian Nicolae (:xti) from comment #8)

> Even when a webpage is saved as PDF, sometimes I get the notification that
> the PDF was saved (downloaded). When the completed notification is not
> triggered, if you close the app and then reopen it again and if you save any
> webpage as PDF, then the previous missing notifications (for completed
> downloads from previous sessions - before closing Fennec) are triggered.

Hm, that's weird. In any case, I think my fix in bug 701797 will take care of any strange behavior because we'll actually be tracking the downloads properly.
You need to log in before you can comment on or make changes to this bug.