Last Comment Bug 701839 - Wrong favicon displayed when both default location and link exists
: Wrong favicon displayed when both default location and link exists
Status: VERIFIED FIXED
[testday-20111111]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P3 normal (vote)
: ---
Assigned To: Brian Nicholson (:bnicholson)
:
:
Mentors:
http://code.google.com/p/selenium/
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-11 13:25 PST by Dave Hunt (:davehunt)
Modified: 2012-01-09 10:29 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
patch (3.42 KB, patch)
2011-11-14 14:42 PST, Brian Nicholson (:bnicholson)
mark.finkle: review+
Details | Diff | Splinter Review

Description Dave Hunt (:davehunt) 2011-11-11 13:25:07 PST
I noticed that the favicon for a Google Code project is using the default favicon for the domain instead of the one specified by the <link> tag.

Steps to reproduce:
1. Open http://code.google.com/p/selenium/

Expected result:
Favicon displayed in awesomebar should be http://www.gstatic.com/codesite/ph/images/phosting.ico

Actual result:
Favicon displayed in awesomebar is http://code.google.com/favicon.ico
Comment 1 John Hammink 2011-11-11 15:25:34 PST
Confirmed on Android 3.1  (Samsung Galaxy Tab 10.1);
and Android 3.2  (Asus Transformer)
Comment 2 John Hammink 2011-11-11 16:06:03 PST
What's more I'm seeing a new issue where content is not actually shown when surfing to the above page.  Entered as:

https://bugzilla.mozilla.org/show_bug.cgi?id=701906
Comment 3 Brian Nicholson (:bnicholson) 2011-11-14 14:42:53 PST
Created attachment 574431 [details] [diff] [review]
patch

It looks like the issue may be caused by this Android bug: http://code.google.com/p/android/issues/detail?id=6066

This patch fully downloads the image before creating a Drawable.
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-14 18:48:05 PST
Comment on attachment 574431 [details] [diff] [review]
patch

Brian, were you able to reproduce the issue and then see this patch fix it?

r+ if we are sure this was the cause and it's fixed now.
Comment 5 Brian Nicholson (:bnicholson) 2011-11-15 10:39:05 PST
Yes; Drawable.createFromStream() was returning null for me (and preventing this specific favicon from loading).  After changing the code to download the entire image first, the favicon loads as expected.
Comment 6 Brian Nicholson (:bnicholson) 2011-11-17 12:59:07 PST
Landed http://hg.mozilla.org/projects/birch/rev/3394b9626828
Comment 7 Catalin Suciu [:csuciu] 2011-11-20 23:41:30 PST
Verified fixed on:
Mozilla/5.0 (Android;Linux armv7l;rv:11.0a1)Gecko/20111117 Firefox/11.0a1 Fennec/11.0a1
Device: Galaxy S
OS: Android 2.2
Comment 8 Catalin Suciu [:csuciu] 2011-11-20 23:43:04 PST
Sorry, this is the actual build:
Mozilla/5.0 (Android;Linux armv7l;rv:11.0a1)Gecko/20111120 Firefox/11.0a1 Fennec/11.0a1

Note You need to log in before you can comment on or make changes to this bug.