Last Comment Bug 701992 - Element FullScreen API should hide Sidebar
: Element FullScreen API should hide Sidebar
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 11
Assigned To: Chris Pearce (:cpearce)
:
Mentors:
Depends on: 714675
Blocks: 545812
  Show dependency treegraph
 
Reported: 2011-11-12 00:52 PST by Alice0775 White
Modified: 2012-05-04 19:40 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
sample html (537 bytes, text/html)
2011-11-12 00:52 PST, Alice0775 White
no flags Details
Patch v1 (1.14 KB, patch)
2011-11-29 18:12 PST, Chris Pearce (:cpearce)
no flags Details | Diff | Review
Patch v1 rebased (1010 bytes, patch)
2011-11-30 12:44 PST, Chris Pearce (:cpearce)
dao+bmo: review-
Details | Diff | Review
Patch v2 (1.15 KB, patch)
2011-12-04 16:18 PST, Chris Pearce (:cpearce)
no flags Details | Diff | Review
Patch v2 rebased (1.05 KB, patch)
2011-12-04 18:06 PST, Chris Pearce (:cpearce)
dao+bmo: review-
Details | Diff | Review
Patch v3 (1.19 KB, patch)
2011-12-05 19:05 PST, Chris Pearce (:cpearce)
dao+bmo: review+
Details | Diff | Review

Description Alice0775 White 2011-11-12 00:52:21 PST
Created attachment 574011 [details]
sample html

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/1374294a6119
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111111 Firefox/11.0a1 ID:20111111031514

Element FullScreen API should hide Sidebar

Reproducible: Always

Steps to Reproduce:
1 Start Firefox with clean profile
2 Open sample html
3 Open Sidebar (Ctrl+B)
4 Click "full" button


Actual Results:
  Sidebar would not be hidden.


Expected Results:
  Sidebar shoould be hidden.
Comment 1 Chris Pearce (:cpearce) 2011-11-29 18:12:40 PST
Created attachment 577823 [details] [diff] [review]
Patch v1

Hide the sidebar when entering DOM full-screen mode.
Comment 2 Dão Gottwald [:dao] 2011-11-30 06:21:59 PST
Comment on attachment 577823 [details] [diff] [review]
Patch v1

patch doesn't apply on mozilla-central tip
Comment 3 Chris Pearce (:cpearce) 2011-11-30 12:44:08 PST
Created attachment 578049 [details] [diff] [review]
Patch v1 rebased

Rebased.
Comment 4 Dão Gottwald [:dao] 2011-12-02 08:31:11 PST
Comment on attachment 578049 [details] [diff] [review]
Patch v1 rebased

This seems to do strange things when the sidebar isn't actually open...

Warning: Empty string passed to getElementById().
Source File: chrome://browser/content/browser.xul
Line: 0

Error: sidebarBroadcaster is null
Source File: chrome://browser/content/browser.js
Line: 8656
Comment 5 Chris Pearce (:cpearce) 2011-12-04 16:18:24 PST
Created attachment 578955 [details] [diff] [review]
Patch v2
Comment 6 Dão Gottwald [:dao] 2011-12-04 16:31:46 PST
Like the first patch, this one doesn't apply cleanly again.
Comment 7 Chris Pearce (:cpearce) 2011-12-04 18:06:47 PST
Created attachment 578966 [details] [diff] [review]
Patch v2 rebased
Comment 8 Dão Gottwald [:dao] 2011-12-05 07:40:21 PST
Comment on attachment 578966 [details] [diff] [review]
Patch v2 rebased

This leaves the side bar splitter on screen (and trying to reopen the side bar just hides the splitter)
Comment 9 Chris Pearce (:cpearce) 2011-12-05 19:05:50 PST
Created attachment 579195 [details] [diff] [review]
Patch v3
Comment 11 Ed Morley [:emorley] 2011-12-08 08:53:13 PST
https://hg.mozilla.org/mozilla-central/rev/21150b624407
Comment 12 Steve Scott (pxbugz) 2012-01-02 14:21:17 PST
I have created bug 701992 since the sidebar is not restored when exiting fullscreen.

I am not sure if this is intentional, as seems to be the case with the find bar here http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#3959
Comment 13 Steve Scott (pxbugz) 2012-01-02 14:22:05 PST
copy paste error, I created Bug 714675

Note You need to log in before you can comment on or make changes to this bug.