event.timeStamp is not the current time

RESOLVED DUPLICATE of bug 238041

Status

()

RESOLVED DUPLICATE of bug 238041
8 years ago
8 years ago

People

(Reporter: dave.methvin, Unassigned)

Tracking

8 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.2 (KHTML, like Gecko) Chrome/15.0.874.120 Safari/535.2

Steps to reproduce:

Examine an Event object when an event is delivered


Actual results:

event.timeStamp is large and appears to be monotonically increasing on subsequent events, but it is not the current time.

http://jsfiddle.net/dmethvin/UtSR8/


Expected results:

event.timeStamp should be the current time (or 0) per the W3C:

http://www.w3.org/TR/2003/NOTE-DOM-Level-3-Events-20031107/events.html#Events-Event-timeStamp
You're about 8 years out of date. Please don't waste time with long-obsolete specs.

http://dev.w3.org/2006/webapi/DOM-Level-3-Events/html/DOM3-Events.html#events-event-type-timeStamp
http://dvcs.w3.org/hg/domcore/raw-file/tip/Overview.html#dom-event-timestamp
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

8 years ago
Sorry about the obsolete reference ... but doesn't the one you linked say the same thing? All the other browsers return a real epoch-based timestamp but Firefox doesn't.
Never mind me, I'm stupid.
Resolution: INVALID → DUPLICATE
Duplicate of bug: 238041
You need to log in before you can comment on or make changes to this bug.