Last Comment Bug 702167 - Sporadic TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug371576-1.html | Wrong order of execution - got ABEF, expected ABCDEF
: Sporadic TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug371576-1.htm...
Status: RESOLVED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: mozilla12
Assigned To: Henri Sivonen (:hsivonen)
:
Mentors:
https://tbpl.mozilla.org/php/getParse...
Depends on: 371576
Blocks: 438871
  Show dependency treegraph
 
Reported: 2011-11-13 17:33 PST by Daniel Holbert [:dholbert]
Modified: 2012-11-25 19:31 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove the test (2.05 KB, patch)
2012-01-13 06:03 PST, Henri Sivonen (:hsivonen)
bugs: review+
Details | Diff | Review

Description Daniel Holbert [:dholbert] 2011-11-13 17:33:58 PST
https://tbpl.mozilla.org/php/getParsedLog.php?id=7377708&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound debug test mochitests-1/5 on 2011-11-13 14:56:52 PST for push 7ff1026f9880
{
9112 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug371576-1.html | Wrong order of execution - got ABEF, expected ABCDEF
}
Comment 1 Jonas Sicking (:sicking) 2011-11-14 15:10:54 PST
Henri has been poking at parser stuff a lot lately. Could this be a regression from that?
Comment 2 Henri Sivonen (:hsivonen) 2011-11-17 06:36:22 PST
This test has been bogus (by depending on a race condition) ever since bug 591981 got fixed. I'm surprised this hadn't gone orange sooner. I think the test should be removed, since there's no obvious way to change the test to make sense in the HTML5-compliant world.
Comment 3 Jonas Sicking (:sicking) 2011-11-17 09:50:59 PST
So do we have tests that ensure that script execution happen in the correct order for both inline and DOM-inserted scripts? And that that order doesn't get messed up if someone sets innerHTML?
Comment 4 Treeherder Robot 2011-12-16 10:31:00 PST
mbrubeck%mozilla.com
https://tbpl.mozilla.org/php/getParsedLog.php?id=7983109&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound opt test mochitests-1/5 on 2011-12-16 09:58:38

9124 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug371576-1.html | Wrong order of execution - got ABEF, expected ABCDEF
Comment 5 Treeherder Robot 2011-12-27 15:43:54 PST
philor
https://tbpl.mozilla.org/php/getParsedLog.php?id=8180685&tree=Firefox
Rev3 WINNT 5.1 mozilla-central pgo test mochitests-1/5 on 2011-12-27 15:16:05

9124 ERROR TEST-UNEXPECTED-FAIL | /tests/content/base/test/test_bug371576-1.html | Wrong order of execution - got ABEF, expected ABCDEF
Comment 6 Henri Sivonen (:hsivonen) 2012-01-13 04:58:21 PST
(In reply to Jonas Sicking (:sicking) from comment #3)
> So do we have tests that ensure that script execution happen in the correct
> order for both inline and DOM-inserted scripts?

There's no "right" order for DOM-inserted scripts. That's why this test should be removed from the tree.
Comment 7 Henri Sivonen (:hsivonen) 2012-01-13 06:03:21 PST
Created attachment 588397 [details] [diff] [review]
Remove the test

The test expect script-inserted scripts to have a deterministic execution order relative to parser-inserted scripts. The premise of the test is wrong per HTML5. See http://hsivonen.iki.fi/script-execution/

There's nothing to replace the test with, because the execution order is non-deterministic by spec.
Comment 8 Olli Pettay [:smaug] 2012-01-13 06:11:33 PST
Comment on attachment 588397 [details] [diff] [review]
Remove the test

rs=me
Comment 9 Henri Sivonen (:hsivonen) 2012-01-13 06:30:11 PST
Thanks.

https://hg.mozilla.org/integration/mozilla-inbound/rev/0153a4156538
Comment 10 Marco Bonardo [::mak] 2012-01-14 01:21:34 PST
https://hg.mozilla.org/mozilla-central/rev/0153a4156538

Note You need to log in before you can comment on or make changes to this bug.