Last Comment Bug 702178 - Remove libxul-rules.mk and libxul-config.mk
: Remove libxul-rules.mk and libxul-config.mk
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: Gregory Szorc [:gps]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-13 19:26 PST by Gregory Szorc [:gps]
Modified: 2011-11-18 11:33 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Move libxul-config.mk and libxul-rules.mk into Makefile, v1 (17.60 KB, patch)
2011-11-14 11:49 PST, Gregory Szorc [:gps]
no flags Details | Diff | Splinter Review
Move libxul-config.mk and libxul-rules.mk into Makefile, v2 (17.70 KB, patch)
2011-11-14 12:48 PST, Gregory Szorc [:gps]
ted: review+
Details | Diff | Splinter Review

Description Gregory Szorc [:gps] 2011-11-13 19:26:02 PST
This is a cleanup/low-priority request to remove toolkit/library/libxul-rules.mk.

This file is only included once, by toolkit/library/Makefile.in. Therefore, it makes no sense to exist as a separate file. The contents can easily be rolled into the aforementioned Makefile.
Comment 1 Gregory Szorc [:gps] 2011-11-13 19:32:59 PST
Looks like libxul-config.mk in the same directory has the same behavior.
Comment 2 Ted Mielczarek [:ted.mielczarek] 2011-11-14 05:06:21 PST
I think these files may have been more useful at one point, but we could definitely just fold them in now.
Comment 3 Gregory Szorc [:gps] 2011-11-14 11:49:45 PST
Created attachment 574364 [details] [diff] [review]
Move libxul-config.mk and libxul-rules.mk into Makefile, v1

This patch simply moves the contents of the extra .mk files inline to toolkit/library/Makefile.in.

There are certainly bits that could be consolidated. I purposefully kept it simple. I can submit a part 2 to perform sanitizing, if requested.
Comment 4 Gregory Szorc [:gps] 2011-11-14 12:08:43 PST
Comment on attachment 574364 [details] [diff] [review]
Move libxul-config.mk and libxul-rules.mk into Makefile, v1

Build failed on my local machine. Looking into it now...
Comment 5 Gregory Szorc [:gps] 2011-11-14 12:48:10 PST
Created attachment 574382 [details] [diff] [review]
Move libxul-config.mk and libxul-rules.mk into Makefile, v2

Same as last except I removed references to the deleted .mk files from EXTRA_DEPS. Tree compiles fine now.
Comment 6 Ted Mielczarek [:ted.mielczarek] 2011-11-16 07:37:40 PST
Comment on attachment 574382 [details] [diff] [review]
Move libxul-config.mk and libxul-rules.mk into Makefile, v2

Review of attachment 574382 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/library/Makefile.in
@@ +86,5 @@
>  	$(NULL)
>  
> +CPPSRCS += \
> +	nsStaticXULComponents.cpp \
> +	$(NULL)

While you're here, can you at least change the formatting on lines you're changing to two-space indent? You don't have to do a ton of cleanup, but that would be nice.
Comment 7 Gregory Szorc [:gps] 2011-11-16 11:01:39 PST
https://hg.mozilla.org/projects/build-system/rev/6f76da3f5e2f

Whitespace changes were made post-review. `hg qdiff -w` had no output. Ted declined additional review on IRC.
Comment 8 Gregory Szorc [:gps] 2011-11-18 11:33:33 PST
https://hg.mozilla.org/mozilla-central/rev/6f76da3f5e2f

Note You need to log in before you can comment on or make changes to this bug.