Closed Bug 702200 Opened 8 years ago Closed 8 years ago

Assertion in nanojit selftest with tr-float

Categories

(Tamarin Graveyard :: Virtual Machine, defect)

x86_64
macOS
defect
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 679840

People

(Reporter: lhansen, Unassigned)

References

Details

tr-float 6825 + a local patch set for Vector.<float4>:

x86_64 Debug build MacOS 10.6, Xcode 3.2.6, SDK 105, gcc 4.0 (according to Xcode):

['test', 'nanojit', 'codealloc', 'allocfree']
Assertion failure: !byteLimit || byteLimit > blkSpaceFor(2) (/Users/lhansen/work/tr-float/platform/mac/avmshell/../../../nanojit/CodeAlloc.cpp:145)
Trace/BPT trap

Does not repeat in TR.
Hard to know where this comes from.  There's new code in nanojit/Allocator.h that handles alignment, but it's not obvious that any of the alignment special cases kick in during the selftest run.
The reason this test does not fail in TR is that the test is not present in TR.
Marking as a duplicate of bug #679840.

The reason that this failure is not seen in tamarin-redux is that the selftest was checked in but was never compiled, so it is not actually running. If you compile the selftest in tamarin-redux you will see the assert.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 679840
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.