Last Comment Bug 702334 - Fix deadlocks caused by Flash
: Fix deadlocks caused by Flash
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P1 normal (vote)
: ---
Assigned To: James Willcox (:snorp) (jwillcox@mozilla.com)
:
Mentors:
Depends on:
Blocks: 695452
  Show dependency treegraph
 
Reported: 2011-11-14 10:22 PST by James Willcox (:snorp) (jwillcox@mozilla.com)
Modified: 2012-01-09 15:03 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
Request java plugin surface asynchronously (and other small fixes) (10.35 KB, patch)
2011-11-14 10:22 PST, James Willcox (:snorp) (jwillcox@mozilla.com)
blassey.bugs: review+
Details | Diff | Splinter Review

Description James Willcox (:snorp) (jwillcox@mozilla.com) 2011-11-14 10:22:25 PST
Created attachment 574334 [details] [diff] [review]
Request java plugin surface asynchronously (and other small fixes)

Gecko does a synchronous round trip to request the plugin surface from the main Android thread. This deadlocks frequently. We should just make it asynchronous, since it's not imperative that the plugin is displayed on the very first paint.
Comment 1 Brad Lassey [:blassey] (use needinfo?) 2011-11-14 17:05:28 PST
Comment on attachment 574334 [details] [diff] [review]
Request java plugin surface asynchronously (and other small fixes)

Review of attachment 574334 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/plugins/base/nsNPAPIPluginInstance.h
@@ +49,4 @@
>  #include "nsIChannel.h"
>  #include "nsInterfaceHashtable.h"
>  #include "nsHashKeys.h"
> +#include "nsIRunnable.h"

put this in a #ifdef ANDROID
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-11-16 06:40:51 PST
https://hg.mozilla.org/projects/birch/rev/924e2318089c

Note You need to log in before you can comment on or make changes to this bug.