Accepting an event invitation does not respect "Bcc these email addresses" account setting

RESOLVED FIXED in 3.3

Status

Calendar
E-mail based Scheduling (iTIP/iMIP)
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: Kim Vandry, Assigned: MakeMyDay)

Tracking

Lightning 1.0b5

Details

Attachments

(1 attachment, 3 obsolete attachments)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

1. In Tools/Account Settings... under "Copies & Folders", checkmark "Bcc these email addresses" and enter an email address. Save this setting. Now *all* outgoing emails should automatically Bcc this email address.

2. Receive an event invitation

3. Accept it


Actual results:

No blind copy of the acceptance email was sent to the configured "always Bcc" address


Expected results:

A blind copy of the acceptance email should have been sent to the configured "always Bcc" address.
Please also see bug 544169. This is not a strict duplicate, but there are certain reasons why BCC might not work out.
Status: UNCONFIRMED → NEW
Depends on: 544169
Ever confirmed: true
(Reporter)

Comment 2

7 years ago
Hi Philipp,

Thanks for the reference to bug 544169.

I would point out that both bug 544169 and bug 549304 are concerned with the list of invitees embedded inside the message but this one is not, so I don't believe it is blocked by those other bugs. The issue I am reporting does not concern the contents of the calendar event, the list of invitees, or anything else inside the message, only the SMTP envelope.

If, under Copies & Folders, I set "Place a copy in..." and specify a "Sent" folder, I expect all emails I send out to be copied to that folder, regardless of whether the outgoing email was a new message, a reply, an autogenerated response, a calendar invitation, a calendar accept/deny/tentative reply, etc... In other words, whenever Thunderbird contacts the SMTP server and delivers an email under any circumstances, I expect it to place a copy in the sent folder.

Similarly, if, under Copies & Folders, I set "Bcc these email addresses", I expect all emails I send out to be Bcc:ed to that address, regardless of whether the outgoing email was a new message, a reply, an autogenerated response, a calendar invitation, a calendar accept/deny/tentative reply, etc... In other words, whenever Thunderbird contacts the SMTP server and delivers an email under any circumstances, I expect it to also add in that extra RCPT To:<> during the SMTP conversation.

So you can see that there is no impact to the calendar logic. It's purely an SMTP thing.

-Phil
Hi Phil,

I do understand your concern, which is why I left this bug open. The problem is that if you bcc someone who is not invited to the event, it will likely look like an invitation to an event to him.

I'm not at all saying this shouldn't be fixed, I fully confirm this bug. I'm just saying that should be kept in mind.
(Reporter)

Comment 4

7 years ago
I understand.

In my use case the Bcc address is a special email address that collects all of my sent email. I fully expect that this email address is not actually invited to the event.
(Assignee)

Comment 5

4 years ago
Created attachment 8365667 [details] [diff] [review]
SupportAutoCcAutoBccInInvitationMails-V1.diff

This patch adds Bcc and Cc recipients to outgoing invitation e-mails if enabled and as specified in the "Copies & Folders" section of the settings of the account used for sending.

This implements not a sanity check on the content of the doCcList/doBccList entries, so if you entered garbage in the settings UI, the sending of the invitation will fail with an error popup. Do we need such a check?
Attachment #8365667 - Flags: review?(philipp)
Assignee: nobody → makemyday
Status: NEW → ASSIGNED
Comment on attachment 8365667 [details] [diff] [review]
SupportAutoCcAutoBccInInvitationMails-V1.diff

Yes, I think some checks here would be helpful. I did a brief check what the mail code does, and they do at least some level of parsing that string into separate recipients.
Attachment #8365667 - Flags: review?(philipp) → review-
(Assignee)

Comment 7

4 years ago
Created attachment 8391947 [details] [diff] [review]
SupportAutoCcAutoBccInInvitationMails-V2.diff

I wondered if there exists an interface in the mail code to check if a string is a fully RfC conforming e-mail address, but I didn't find one. So, the updated patch implements a basic check whether the value of doCcList/doBccList is an e-mail address or a comma separated list of those.
Attachment #8365667 - Attachment is obsolete: true
Attachment #8391947 - Flags: review?(philipp)
Attachment #8391947 - Attachment is patch: true
Attachment #8391947 - Attachment mime type: text/x-patch → text/plain
Comment on attachment 8391947 [details] [diff] [review]
SupportAutoCcAutoBccInInvitationMails-V2.diff

As far as I can see, this is (simplified) what Thunderbird does:

let compFields = Components.classes["@mozilla.org/messengercompose/composefields;1"].createInstance(Components.interfaces.nsIMsgCompFields)
let recipients = compFields.splitRecipients(identity.doBccList, false, {});


Recipients should give you an array of correctly encoded email addresses. This doesn't do a full validation (i.e oajsndfsojdnfasdf@asfasd will appear as a recipient), but I think this gets us close enough to what Thunderbird does.

Could you incorporate this?
Attachment #8391947 - Flags: review?(philipp) → review-
(Assignee)

Comment 9

4 years ago
Created attachment 8393081 [details] [diff] [review]
SupportAutoCcAutoBccInInvitationMails-V3.diff

I added this, but let it it in calUtils.jsm - we will need this for bug 984119 as well to add a similar functionality there, too.
Attachment #8393081 - Flags: review?(philipp)
Comment on attachment 8393081 [details] [diff] [review]
SupportAutoCcAutoBccInInvitationMails-V3.diff

Review of attachment 8393081 [details] [diff] [review]:
-----------------------------------------------------------------

r=philipp
Attachment #8393081 - Flags: review?(philipp) → review+
Created attachment 8394491 [details] [diff] [review]
Fix - v4

Patch for checkin with full headers, tree is still closed.
Attachment #8394491 - Flags: review+
Keywords: checkin-needed
Attachment #8391947 - Attachment is obsolete: true
Attachment #8393081 - Attachment is obsolete: true
https://hg.mozilla.org/comm-central/rev/30d1d947dd94
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 3.3
Component: General → E-mail based Scheduling (iTIP/iMIP)
You need to log in before you can comment on or make changes to this bug.