crash in js::detail::RegExpPrivate::decref

RESOLVED FIXED in mozilla10

Status

()

Core
JavaScript Engine
--
critical
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Robert Kaiser, Unassigned)

Tracking

({crash, regression})

10 Branch
mozilla10
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
This bug was filed from the Socorro interface and is 
report bp-190bf26c-8679-45ab-b3c9-0405c2111114 .
============================================================= 

This happens on both 10.0a2 Aurora and 11.0a1 Nightly, just that the signature changed from js::RegExpPrivate::decref to js::detail::RegExpPrivate::decref

It looks like this started right around the uplift day, the first crashes are from 2011-11-09 on both channels.

Comment 1

6 years ago
Should track volume and see what happens.

Comment 3

6 years ago
With combined signatures, it's #4 top crasher in 10.0a2 and 11.0a1.
tracking-firefox10: --- → ?
tracking-firefox11: --- → ?
Blocks: 634654

Updated

6 years ago
Keywords: regression
Version: Trunk → 10 Branch

Updated

6 years ago
Crash Signature: [@ js::detail::RegExpPrivate::decref(JSContext*)] [@ js::RegExpPrivate::decref(JSContext*)] → [@ js::detail::RegExpPrivate::decref(JSContext*)] [@ js::RegExpPrivate::decref(JSContext*)] [@ JSContext::delete_<js::RegExpPrivate>(js::RegExpPrivate*) ]
(Reporter)

Comment 4

6 years ago
No crashes any more with builds from 2011-11-15 or later, it seems. Fixed by bug 701761 perhaps?

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
tracking-firefox10: ? → ---
tracking-firefox11: ? → ---
Resolution: --- → FIXED
Target Milestone: --- → mozilla10
You need to log in before you can comment on or make changes to this bug.