Closed Bug 702384 Opened 10 years ago Closed 10 years ago

Crashes in signature summary should match the rest of the reports/list page

Categories

(Socorro :: General, task)

task
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: kairo, Assigned: brandon)

References

Details

Currently (in 2.3.3), when looking at a reports/list for a restricted set of data, e.g. Firefox 8.0 only, we get a signature summary across all reports.

See bug 642336 comment #52 for some details on this.
Assignee: nobody → josh
Target Milestone: --- → 2.3.4
Target Milestone: 2.3.4 → 2.4
Josh is going to be unavailable until after the 2.3.4 release branches, hence -> 2.4.
Assignee: josh → bsavage
Target Milestone: 2.4 → 2.3.4
Target Milestone: 2.3.4 → 2.4
Component: Socorro → General
Product: Webtools → Socorro
Matview needs changes.  taking bug.
Assignee: bsavage → josh
Depends on: 714338
Blocks: 701813
Target Milestone: 2.4 → 2.4.1
Josh has made the needed changes. Reassigning to self to resolve the remaining items.
Assignee: josh → bsavage
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
(In reply to Brandon Savage [:brandon] from comment #3)
> Josh has made the needed changes. Reassigning to self to resolve the
> remaining items.

Per conversation in irc with brandonsavage slight clarification:
"Making sure that the product and version are passed to the backend so that the numbers match. E.g. when viewing a signature summary for X crash in Y product and Z version, it should match the reports."
Reopening, my understanding is that a reports/list signature summary should only include the filtered product. For the below query I am seeing for Thunderbird, Seamonkey, FennecAndroid, and Firefox in the signature summary tab.

https://crash-stats.allizom.org/report/list?range_value=7&range_unit=days&date=2012-01-31&signature=EMPTY%3A%20no%20crashing%20thread%20identified%3B%20corrupt%20dump&version=Firefox%3A12.0a1


======
As a point of reference for the github bot I believe this is the commit you were looking for - 

https://github.com/mozilla/socorro/commit/24d42ed77a6a7341dd5538049154c9c96568df27
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Mbrandt:

The exception is the "products" signature summary, which should *not* filter on the current selected product(s).  Otherwise it would be fairly useless.  So that's intentional.

However, all the other summaries should include only the currently selected product.  This is also why the totals don't match.
Bumping back to resolved per comment 6.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
thx :jberkus, comment 0 mentioned "signature summary" and I mistook that for meaning the signature summary tab.

Bumping this to qa verified. Spot checked several versions of Firefox, Thunderbird, FennecAndroid, and Fennec.
Status: RESOLVED → VERIFIED
It's everything *except* the Products breakdown.  Confusing, yes, I know.  We'll see how many actual users are confused ...
Seems like something we could document and/or inform actual users about in a later version. I expect they WILL be confused.
(In reply to [:jberkus] Josh Berkus from comment #9)
> It's everything *except* the Products breakdown.  Confusing, yes, I know. 

Actually, that was *not* my intent when I filed this. It was intended to have the "products" breakdown to be filtered the same way. It would be intentional to indicate that the results are only one product (and version, potentially). The way it is now it's really confusing as hell as numbers don't match at all and no description tells about why that is.
Kairo,

Ah, I asked you about this in a fair bit of detail.  I guess you weren't clear what I was asking without a demo.

Up to Brandon if he can change it for 2.4.1; it might require waiting for 2.4.2.
You need to log in before you can comment on or make changes to this bug.