Last Comment Bug 702483 - Rename heap-committed-unallocated-fraction to heap-committed-fragmentation
: Rename heap-committed-unallocated-fraction to heap-committed-fragmentation
Status: RESOLVED FIXED
[qa-]
:
Product: Toolkit
Classification: Components
Component: about:memory (show other bugs)
: unspecified
: x86 Windows 7
: -- normal (vote)
: mozilla11
Assigned To: Hugh Nougher [:Hughman]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-14 16:45 PST by Hugh Nougher [:Hughman]
Modified: 2012-02-01 14:00 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Patch (2.30 KB, patch)
2011-11-14 19:51 PST, Hugh Nougher [:Hughman]
no flags Details | Diff | Splinter Review
PatchV2 (2.50 KB, patch)
2011-11-14 21:17 PST, Hugh Nougher [:Hughman]
justin.lebar+bug: review+
Details | Diff | Splinter Review

Description Hugh Nougher [:Hughman] 2011-11-14 16:45:51 PST
heap-committed-unallocated-fraction is confusing when reading on context of the memory reporters around it since its actually (heap-allocated / heap-committed).

It was decided in #memshrink with jlebar that heap-committed-fragmentation was a better name for it.
Comment 1 Hugh Nougher [:Hughman] 2011-11-14 19:51:10 PST
Created attachment 574516 [details] [diff] [review]
Patch

Changed reporter path and related variables around with same name.
Comment 2 Daniel Holbert [:dholbert] 2011-11-14 20:02:01 PST
Pushed to try, at Hugh's request.
Results will show up here: https://tbpl.mozilla.org/?tree=Try&rev=4dfae5242574
Comment 3 Hugh Nougher [:Hughman] 2011-11-14 21:17:07 PST
Created attachment 574535 [details] [diff] [review]
PatchV2

V2 now with user and commit message! (hopefully)
Comment 4 Hugh Nougher [:Hughman] 2011-11-15 01:10:47 PST
Comment on attachment 574535 [details] [diff] [review]
PatchV2

Try run looks like it has no fails except unrelated and things that were failing on m-c at push time.

So I think the next thing to do is get review, and who better than the person who I needed to ask about the problem in the first place?
Comment 5 Justin Lebar (not reading bugmail) 2011-11-15 09:50:50 PST
Comment on attachment 574535 [details] [diff] [review]
PatchV2

lgtm!
Comment 6 Justin Lebar (not reading bugmail) 2011-11-15 09:53:18 PST
Pushed to mozilla-inbound: https://hg.mozilla.org/integration/mozilla-inbound/rev/f76ac3b9fcf2
Comment 7 Justin Lebar (not reading bugmail) 2011-11-15 22:23:01 PST
And I forgot to include the reviewer in the commit message.  Oh well.
Comment 8 Ed Morley [:emorley] 2011-11-16 03:16:27 PST
https://hg.mozilla.org/mozilla-central/rev/f76ac3b9fcf2

Note You need to log in before you can comment on or make changes to this bug.