Last Comment Bug 702779 - Up-to-date communication on Developer Tools vision and progress
: Up-to-date communication on Developer Tools vision and progress
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: 10 Branch
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Kevin Dangoor
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-15 14:28 PST by Florens Verschelde
Modified: 2011-11-19 01:36 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Florens Verschelde 2011-11-15 14:28:21 PST
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:10.0a2) Gecko/20111115 Firefox/10.0a2
Build ID: 20111115042021

Steps to reproduce:

It seems there has not been much recent communication on Developer Tools. For instance there has been no new post on http://blog.mozilla.com/devtools/ for the past 2 months, while some developer tool prototypes have landed in Firefox (Aurora at least, maybe Beta as well?) during this period.

My current impression is that:
- the new developer tools are promoted in release notes in order to get more testing/bug reports, with words that may set high expectations;
- but the tools are prototypes, some of them quite crude or crude-looking, and will evolve a lot.

What's missing from this picture is an overview of what is planned for the built-in Developer Tools in Firefox, and some information on how far along the road the project is.

Defining what the vision/goal is: there is an old post at http://blog.mozilla.com/devtools/2011/05/25/the-relationship-between-firebug-and-mozilla-developer-tools/ which basically says “we want to try something different”. An update with an overview of the planned feature set and maybe some mockups would be nice.

Reporting on the current progress: I suggest a blog post on http://blog.mozilla.com/devtools/ before each Aurora release, assessing the overall progress (like, “we’re roughly 40% done” or something subtler) and listing highlights. Release notes, tweets, etc. would then link to that post.

Just my feedback and some ideas.


Actual results:

—


Expected results:

—
Comment 1 Rob Campbell [:rc] (:robcee) 2011-11-15 15:31:40 PST
Hi Florent.

Thanks for the bug report. This is definitely something we need to do better so thanks for calling us on it. I personally have been meaning to blog more about some of the stuff we've been landing in recent releases but have been busy building these features.

I know Kevin Dangoor is working on a Highlighter related post and in the coming days and weeks, we're putting together a more concrete roadmap about our ongoing feature-work. We have a lot of exciting stuff in the pipe and we're very eager to get it in. I'll write about some of this upcoming work very shortly.

I'm giving myself a deadline of Nov 30th to have something posted to the Devtools blog.
Comment 2 Kevin Dangoor 2011-11-15 18:00:08 PST
Hi Florent,

What Rob has said here is true, and I'll add a couple more comments on top of that.

1. The Planet Mozilla people said that they were going to start removing blogs that were not from individuals (I don't have the link to that), so I started posting more to my own blog. I see now that the devtools blog is still on the Planet, so I'll go back to posting there. I agree wholeheartedly that the visibility is better there, as long as it's on the Planet.

2. there isn't a good landing page for high-level info about the tools. We're planning that for the Firefox 10 cycle.

3. The most recent roadmap is here:

https://wiki.mozilla.org/DevTools/RoadmapJune2011

A lot has changed already since June, and a new roadmap (for 2012) will be up for comment shortly.

4. You can get an idea of features that are in play here:

https://wiki.mozilla.org/Features/DevTools

But, that format is much more intended for people implementing things than for people who are just interested in what's going on.


Also, I'll note that ideally I would have been a bit more timely with a detailed blog post for this Aurora. For a variety of reasons, I haven't gotten the post up yet. Unless something comes up, it will be there tomorrow.


Thanks a lot for the prodding. It's great to have interest and I hope the next set of posts are informative for you.
Comment 3 Kevin Dangoor 2011-11-16 11:02:17 PST
Blog post is up on Mozilla Hacks. I'll resume weekly updates on the devtools blog and post it there tomorrow as well.

http://hacks.mozilla.org/2011/11/developer-tools-in-firefox-aurora-10/

if it's fine with you, I'll close this bug tomorrow after posting that update. Sound good?
Comment 4 Kevin Dangoor 2011-11-17 11:51:03 PST
And the return of the project status highlights:

http://blog.mozilla.com/devtools/2011/11/17/weekly-developer-tools-update-nov-17/
Comment 5 Florens Verschelde 2011-11-19 01:36:33 PST
Thanks for the updates. :)

Note You need to log in before you can comment on or make changes to this bug.