Allow custom themes while using personas

RESOLVED DUPLICATE of bug 520124

Status

()

Firefox
Theme
RESOLVED DUPLICATE of bug 520124
6 years ago
6 years ago

People

(Reporter: KLB, Unassigned)

Tracking

9 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 574865 [details]
Personas and theme working togther via "hack"

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

When personas first came out as a separate extension, users were able to use personas on custom themes.  The drawback to this was that at first custom themes frequently didn't work well with custom themes.  In time, however, some theme developers went to great pains to make their themes compatible with personas. Unfortunately, once personas was rolled into Firefox, custom theme support was disabled.

Some time ago a proposal was made to provide an RDF tag that theme developers could use that would indicate if their theme was personas compatible. That tag was:
<em:skinnable>true</em:skinnable>

At some point in the past year or so it was indicated that providing custom theme support with personas was being worked on. Unfortunately, those efforts seemed to have fallen to the wayside. I'd like to propose that this effort be resumed.

Currently, due to a bug in personas, users are able to force personas and custom themes to work together, however, it is very cumbersome and requires several restarts of Firefox. Instructions for seeing how to apply custom themes and personas together can be seen at: https://forums.mozilla.org/addons/viewtopic.php?f=30&t=2636

I've attached an image file demonstrating my theme "Classic Compact" working with a persona via the hack detailed in the forum thread I referenced above. I'll post a screen shot of what the themes tab in about:addons looks like when a custom theme and persona are both enabled with my second post to this bug.
(Reporter)

Comment 1

6 years ago
Created attachment 574867 [details]
about:addons appearance tab with custom theme and persona active.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 520124
You need to log in before you can comment on or make changes to this bug.