Closed Bug 702968 Opened 10 years ago Closed 9 years ago

Firefox 11 x64 20% slower than 32bit in Google V8

Categories

(Core :: JavaScript Engine, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 650063

People

(Reporter: speciesx, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: perf)

Attachments

(1 file)

Attached image google v8.png
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:11.0a1) Gecko/20111116 Firefox/11.0a1
Build ID: 20111116030946

Steps to reproduce:

Comparing the speed of Firefox 32bit & 64bit (current trunk) in Google V8 Benchmark.


Actual results:

32bit
Score: 6025
Richards: 8095
DeltaBlue: 10189
Crypto: 14849
RayTrace: 3123
EarleyBoyer: 7012
RegExp: 1174
Splay: 9151

64bit
Score: 4939
Richards: 6926
DeltaBlue: 7002
Crypto: 10057
RayTrace: 2957
EarleyBoyer: 5692
RegExp: 1225
Splay: 7130


Expected results:

On Peacekeeper, Mozilla Kraken and SunSpider has 32bit & 64bit nearly the same speed, why on V8 the big difference?
Hardware: x86 → x86_64
Where is Google V8 Benchmark available?
(In reply to Andre Klapper from comment #1)
> Where is Google V8 Benchmark available?

http://v8.googlecode.com/svn/data/benchmarks/v6/run.html
yep i can confirm this but believe me head firefox devs are aware of this
Keywords: perf
Depends on: 783578
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
We're tracking progress of V8 in general and the various single benchmark individually in several bugs already.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 650063
You need to log in before you can comment on or make changes to this bug.