Flash content usage Crash [@ JNI_CreateJavaVM | libflashplayer.so@0x5766dd ]

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
P4
critical
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: tchung, Unassigned)

Tracking

({crash, reproducible})

unspecified
ARM
Android
crash, reproducible
Points:
---

Firefox Tracking Flags

(firefox11 affected, firefox12 affected)

Details

(Whiteboard: [native-crash], crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 574929 [details]
logcat

Crashing on libflashplayer.so while panning around flash heavy sites.   

https://crash-stats.mozilla.com/report/index/bp-3e3796b2-8de5-4727-bf48-bf31d2111116
https://crash-stats.mozilla.com/report/index/bp-a4d5b87f-b517-4644-b0f7-78ae92111116

Repro:
1) install nightly birch, SGS2: Mozilla/5.0 (Android; Linux armv7l; rv:10.0a1)
Gecko/20111116 Firefox/10.0a1 Fennec/10.0a1
2) visit a heavy crash site (see URL)
3) pan around, click on flash content, just play with the site
4) Verify fennec crashes within 2-5 minutes, and crash reporter UI appears

Not very helpful stack:
Frame 	Module 	Signature [Expand] 	Source
0 	libdvm.so 	JNI_CreateJavaVM 	
1 	libflashplayer.so 	libflashplayer.so@0x5766dd 	
2 	libflashplayer.so 	libflashplayer.so@0x57728b 	
3 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x87bc2 	
4 	libflashplayer.so 	libflashplayer.so@0x8ba04e 	
5 	libflashplayer.so 	libflashplayer.so@0x48e08d 	
6 	libflashplayer.so 	libflashplayer.so@0xa2a4e2 	
7 	libflashplayer.so 	libflashplayer.so@0x5771b7 	
8 	libflashplayer.so 	libflashplayer.so@0x8b136a 	
9 	libflashplayer.so 	libflashplayer.so@0x577371 	
10 	libflashplayer.so 	libflashplayer.so@0xa2a4e2 	
11 	libflashplayer.so 	libflashplayer.so@0x55e49b 	
12 	libflashplayer.so 	libflashplayer.so@0xa2a4e2 	
13 	libflashplayer.so 	libflashplayer.so@0x560ac1 	
14 	libc.so 	pthread_mutex_lock 	

Expected:
- no crashing

Updated

7 years ago
Priority: -- → P4
could you please test in the stock browser to see if it handles this page
Keywords: reproducible
Whiteboard: [native-crash] → [native-crash:P1]
I don't seem to crash on this page with build 20111130.  tchung, can you verify?

Updated

7 years ago
Depends on: 704161
(Reporter)

Comment 3

7 years ago
(In reply to Naoki Hirata :nhirata from comment #2)
> I don't seem to crash on this page with build 20111130.  tchung, can you
> verify?

Repro'd on 2012-01-17 Fennec Nightly, SGS2 again.
Got the crash again doing the same steps from comment 0 on this site.  Here's the latest crash report: https://crash-stats.mozilla.com/report/index/bp-1451f698-5b60-43a1-a31d-662d22120122

Also tested this for awhile on stock android.  never got it to crash once.
Only seems to have happened on Native.
status-firefox11: --- → affected
status-firefox12: --- → affected
Whiteboard: [native-crash:P1] → [native-crash]
(In reply to Naoki Hirata :nhirata from comment #4)
> Only seems to have happened on Native.

I cannot reproduce this crash on the latest Nightly build. When I perform the reproducing steps from comment #0, Bug 719872 always occurs.
Should I close it as WFM?

--
Mozilla/5.0 (Android;Linux armv7l;rv:12.0a1)Gecko/20120125
Firefox/12.0a1 Fennec/12.0a1
Device: Samsung Galaxy S, Samsung Nexus S
OS: Android 2.2, Android 2.3.6
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
I'm seeing this crash now with the testcase in bug 694992, http://people.mozilla.com/~mwargers/tests/dvmstringlength/crash1.htm
See bug 694992, comment 8.
You need to log in before you can comment on or make changes to this bug.