Minimize memory usage in about:memory should run shrinking GC

RESOLVED DUPLICATE of bug 699279

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 699279
6 years ago
6 years ago

People

(Reporter: Igor Bukanov, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
+++ This bug was initially created as a clone of Bug #670596 +++

Currently there is no way in about:memory to trigger the shrinking GC that releases all empty GC chunks and decommits unused GC arenas. It would be nice if the "Minimize memory usage" button or even the "GC" button should run a shrinking GC.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 699279
(Reporter)

Comment 2

6 years ago
(In reply to Justin Lebar [:jlebar] from comment #1)
> 
> *** This bug has been marked as a duplicate of bug 699279 ***

I though bug 699279 was about doing the shrinking GC under memory pressure. This is unrelated to about:memory GUI.
When you click minimize memory usage in about:memory, it does a memory pressure event.
You need to log in before you can comment on or make changes to this bug.