Last Comment Bug 703123 - web console "Web Developer" filter button should be renamed
: web console "Web Developer" filter button should be renamed
Status: RESOLVED FIXED
[fixed-in-fx-team][strings]
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 11
Assigned To: Sonny Piers [:sonny]
:
Mentors:
Depends on:
Blocks: 703615
  Show dependency treegraph
 
Reported: 2011-11-16 15:33 PST by Heather Arthur [:harth]
Modified: 2011-11-22 06:37 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1 (1.35 KB, patch)
2011-11-19 05:53 PST, Sonny Piers [:sonny]
mihai.sucan: review+
Details | Diff | Review
patch v1.1 (1.56 KB, patch)
2011-11-19 06:27 PST, Sonny Piers [:sonny]
mihai.sucan: review+
dao+bmo: review-
Details | Diff | Review
patch v2 (5.92 KB, patch)
2011-11-20 07:22 PST, Sonny Piers [:sonny]
dao+bmo: review+
Details | Diff | Review
patch v2.1 (5.99 KB, patch)
2011-11-21 02:46 PST, Sonny Piers [:sonny]
no flags Details | Diff | Review

Description Heather Arthur [:harth] 2011-11-16 15:33:37 PST
The filter button for filtering console.log() etc messages should be renamed from "Web Developer".

I was talking to a web dev, and he said "I don't use that 'Web Developer' button, whatever that is". I remember an initial confusion with the naming too, and continuing confusion even though I know what it is now.

I suggest "Logging".
Comment 1 Dave Camp (:dcamp) 2011-11-16 15:40:58 PST
Yeah, that makes more sense to me.
Comment 2 Heather Arthur [:harth] 2011-11-18 11:45:26 PST
Commented in https://bugzilla.mozilla.org/show_bug.cgi?id=703615#c2 too, but I forgot to mention here that potch also suggested merging the 'Web Developer' options under 'JS'.
Comment 3 Rob Campbell [:rc] (:robcee) 2011-11-18 12:16:51 PST
(In reply to Heather Arthur [:harth] from comment #2)
> Commented in https://bugzilla.mozilla.org/show_bug.cgi?id=703615#c2 too, but
> I forgot to mention here that potch also suggested merging the 'Web
> Developer' options under 'JS'.

Respectfully disagree because of what I said in https://bugzilla.mozilla.org/show_bug.cgi?id=703615#c3.
Comment 4 Sonny Piers [:sonny] 2011-11-19 05:53:52 PST
Created attachment 575657 [details] [diff] [review]
patch v1
Comment 5 Mihai Sucan [:msucan] 2011-11-19 06:16:27 PST
Comment on attachment 575657 [details] [diff] [review]
patch v1

Review of attachment 575657 [details] [diff] [review]:
-----------------------------------------------------------------

Patch looks good. Thank you Sonny!

Please also update the localization note.
Comment 6 Sonny Piers [:sonny] 2011-11-19 06:27:26 PST
Created attachment 575661 [details] [diff] [review]
patch v1.1
Comment 7 Mihai Sucan [:msucan] 2011-11-19 07:19:35 PST
Axel: should we rename the property name as well?
Comment 8 Francesco Lodolo [:flod] 2011-11-19 08:26:51 PST
(obviously not Axel) Yes, please rename the property to make all localizers aware of this change. 

Not sure if the "page" explanation in the localization note is still needed, since "Logging" is easier to understand. Maybe this is enough?

# This is used as the label for the "Logging" button on the toolbar. It
# shows or hides messages that the web developer inserted on the page for
# debugging purposes, using calls such console.log() and console.error().
Comment 9 Sonny Piers [:sonny] 2011-11-19 09:26:45 PST
I think we should conserve the page explanation because others menus are about logging stuffs too.
Tell me what you think.
Comment 10 Dão Gottwald [:dao] 2011-11-20 01:37:26 PST
Comment on attachment 575661 [details] [diff] [review]
patch v1.1

Yes, you need to change the property name.
Comment 11 Sonny Piers [:sonny] 2011-11-20 07:22:38 PST
Created attachment 575744 [details] [diff] [review]
patch v2
Comment 12 Dão Gottwald [:dao] 2011-11-20 23:38:08 PST
Comment on attachment 575744 [details] [diff] [review]
patch v2

> # This is used as the text of the tool tip for the "Web Developer" button on
> # the toolbar.

Still need to replace "Web Developer" with "Logging" here. Looks good otherwise. Thanks!
Comment 13 Sonny Piers [:sonny] 2011-11-21 02:46:29 PST
Created attachment 575828 [details] [diff] [review]
patch v2.1
Comment 14 Sonny Piers [:sonny] 2011-11-21 02:49:28 PST
Fixed!
Comment 15 Rob Campbell [:rc] (:robcee) 2011-11-21 12:55:14 PST
https://hg.mozilla.org/integration/fx-team/rev/971edb844b3d
Comment 16 Rob Campbell [:rc] (:robcee) 2011-11-22 06:37:05 PST
https://hg.mozilla.org/mozilla-central/rev/971edb844b3d

Note You need to log in before you can comment on or make changes to this bug.