[Regression] Selection does not work in main apprunner window

VERIFIED FIXED in M6

Status

()

P2
major
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: mcafee, Assigned: slamm)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Linux.
I cannot select text in the main apprunner window.
This is a regression from earlier today, 11am?

Selection works in the editor.  Ramiro mentioned that the
new sidebar behavior might be to blame.?
(Reporter)

Updated

20 years ago
Target Milestone: M6

Comment 1

20 years ago
no cause i never commited the changes.
(Reporter)

Updated

20 years ago
Assignee: don → slamm
(Reporter)

Comment 2

20 years ago
Reverting slamm's one-line change to navigator.xul switches
back to the old frame behavior AND fixes the selection problem.
slamm?
(Reporter)

Updated

20 years ago
Severity: normal → major
Priority: P3 → P2

Comment 3

20 years ago
is this an xp bug ? does it happen on win32?

Comment 4

20 years ago
in the latest release build on my win95 laptop I can select
in the editor, but not on a browser page.
(Reporter)

Updated

20 years ago
OS: Linux → All
Hardware: PC → All
(Reporter)

Comment 5

20 years ago
marking XP

Comment 6

20 years ago
Is selection being disabled for chrome web shells (as opposed to content
shells)?  If slamm made a change that affected the structure of navigator.xul
and didn't label the content area as a content shell then that might
explain this.

For any area that is supposed to be a content frame, you should have the
attribute type set to a value of "content" on the content frame, e.g.,

<iframe type="content"....

If editor has code that turns selection off for chrome shells, this would
explain the problem.

Comment 7

20 years ago
take ramiro out of cc
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 8

20 years ago
I am using iframe's instead of a frameset now. I did mislabel the content. I had
id="content" instead of type="content". However, in my tree selection still does
not work with that change.

I will investigate some more.
(Assignee)

Comment 9

20 years ago
chofmann, I would like to back out my change until I get this straightened out.
Fortunately, switching back is easy,

Index: navigator.xul
===================================================================
RCS file: /cvsroot/mozilla/xpfe/browser/src/navigator.xul,v
retrieving revision 1.112
diff -r1.112 navigator.xul
605c605
<   <html:iframe id="content-frame" src="contentframe.xul" flex="100%" />
---
>   <html:iframe id="content-frame" src="contentframe.html" flex="100%" />
(Assignee)

Comment 10

20 years ago
mcafee, I backed out my change (in my tree), but I still see the selection
problem.

Extra details: If I make a selection, I do not see it immediately under the
mouse. However, if I scroll that area off screen and then bring it back, the
selection is drawn in the proper place.
*** Bug 7054 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

20 years ago
I checked in a fix. I added type="content" to the iframe in contentframe.xul.
Marking fixed.

Updated

20 years ago
Component: Apprunner → Selection and Search
QA Contact: leger → claudius

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 13

20 years ago
VERIFIED fixed for every build I could get my hands on including Mac, Linux, and WinNT 19990601 builds.

Comment 14

19 years ago
Per a request from Selection and Search component eng (mjudge) and qa (elig),
moving all "Selection and Search" bugs to new "Selection" component.  Original
"Selection and Search" component will be retired.
You need to log in before you can comment on or make changes to this bug.