Last Comment Bug 703360 - Image is not visible when placed inside hidden div with text-overflow: ellipsis
: Image is not visible when placed inside hidden div with text-overflow: ellipsis
Status: RESOLVED DUPLICATE of bug 690187
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: 8 Branch
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks: 312156
  Show dependency treegraph
 
Reported: 2011-11-17 12:41 PST by Pavel
Modified: 2011-12-14 17:15 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
clip.html (574 bytes, text/html)
2011-11-17 12:41 PST, Pavel
no flags Details

Description Pavel 2011-11-17 12:41:26 PST
Created attachment 575268 [details]
clip.html

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

	<style>
		.clippedDiv {
			background: #d7d7d7;
			border: 1px solid #000000;
			overflow: hidden;
			text-overflow: ellipsis;
		}
	</style>

<div class="clippedDiv" style="width: 100px">
	<img src="http://www.bobbernhardt.com/img/google.jpg">
</div>



Actual results:

text-overflow: ellipsis; only started to work in FF 7.0. They work fine with text. However when I use img as my inline content then instead of clipping image(as it is done in all other browsers) FF does not show image at all


Expected results:

I attached simple html file that illustrates this problem. Try to run it in different browsers other then FF7 or FF8.

It breaks backwards compatibility and pages and used to show clipped images in FF3/4/5 now stopped showing images
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2011-11-17 19:05:50 PST
This is the behavior the spec requires.... Yes, it does not match what other browsers implemented.
Comment 2 j.j. 2011-11-17 20:02:57 PST

*** This bug has been marked as a duplicate of bug 690131 ***
Comment 3 j.j. 2011-12-14 17:15:43 PST
The specification changed an this might be fixed soon.

*** This bug has been marked as a duplicate of bug 690187 ***

Note You need to log in before you can comment on or make changes to this bug.