Give Unix developers that ability to build PSM 2.0

VERIFIED FIXED

Status

SeaMonkey
Build Config
VERIFIED FIXED
17 years ago
12 years ago

People

(Reporter: Javier Delgadillo, Assigned: Javier Delgadillo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Assignee)

Description

17 years ago
As you all know, we've been working on PSM 2.0 (an in process replacement for
PSM 1.x which mozilla currently builds).  We're far along now where we'd like to
give other developers the ability to build PSM and try it out for themselves.

I'm attaching the patch I currently use to build PSM 2.0 on Linux.  

Unfortunately, this patch requires that PSM 2.0 be built after a full mozilla
build has been completed so that all of NSS's dependencies are in place.
(Assignee)

Comment 1

17 years ago
Created attachment 26298 [details] [diff] [review]
Patch for enabling PSM 2.0 for developers.
(Assignee)

Comment 2

17 years ago
Created attachment 26412 [details] [diff] [review]
Updated patch that keeps NSS_CLIENT_TAG as default version of NSS

Comment 3

17 years ago
Created attachment 26496 [details] [diff] [review]
Changes to make psm2 build using BUILD_MODULES
(Assignee)

Comment 4

17 years ago
r=javi on this patch.  For the final patch, I'll also do a global search and
replace.  s/gmake/$(MAKE)
(Assignee)

Comment 5

17 years ago
cls:

I've tried your patch and it works great.  Can I go ahead and check it in?

Comment 6

17 years ago
Go for it.
(Assignee)

Comment 7

17 years ago
Patch checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.