cannot zoom text size on "view page info" page

RESOLVED WORKSFORME

Status

()

Firefox
Disability Access
--
enhancement
RESOLVED WORKSFORME
7 years ago
10 months ago

People

(Reporter: Dan Jacobson, Unassigned)

Tracking

10 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:10.0a2) Gecko/20111114 Firefox/10.0a2 Iceweasel/10.0a2
Build ID: 20111114042039

Steps to reproduce:

When browsing any page's "View Page Info", one finds CTRL++ is disabled.
One can only browse "View Page Info" at one single Company approved text size.



Expected results:

While you are at it do add a menu zoom item there in case one does not know about CTRL++.

Comment 1

7 years ago
View Page info is not a website, it's a dialog, much like Tools/Options is. The page zoom feature is what it is, a page zoom feature which doesn't work in *any* dialog AFAIK.
(Reporter)

Comment 2

7 years ago
I saw some text in the box labeled Meta that I wanted to zoom at least.

Comment 3

7 years ago
(In reply to Marco Zehe (:MarcoZ) from comment #1)
> View Page info is not a website, it's a dialog, much like Tools/Options is.
> The page zoom feature is what it is, a page zoom feature which doesn't work
> in *any* dialog AFAIK.

Btw, Marco, why does Firefox not allow zoom feature to work on Firefox UI like dialogs. Is it area of desktop capabilities? I'm curious if it's not handy to have unified zoom in Firefox.

Comment 4

7 years ago
Well, since we have the control over all widgets, I suppose we *could* implement it. "We" being Mozilla in general. But the current Zoom feature de facto only works on website content. That's why this is rahter an enhancement request than a bug.
Dialogs sizes are supposed to be controlled by the os/desktop AIUI.

Comment 6

7 years ago
(In reply to David Bolter [:davidb] from comment #5)
> Dialogs sizes are supposed to be controlled by the os/desktop AIUI.

right, the same can be applicable at some precision to web content in means desktop can affect on it. 

The question is how much is this feature handy/useful for user?
Severity: normal → enhancement
OS: Linux → All
Hardware: x86 → All
Another question might be: if a user zooms their desktop, should content zoom? I would guess no.

Comment 8

7 years ago
(In reply to David Bolter [:davidb] from comment #7)
> Another question might be: if a user zooms their desktop, should content
> zoom? I would guess no.

I think it should, that's part of integration with OS. Btw, Firefox doesn't do that currently but that's reverse bug to this one.

Comment 9

7 years ago
(In reply to alexander surkov from comment #8)
> (In reply to David Bolter [:davidb] from comment #7)
> > Another question might be: if a user zooms their desktop, should content
> > zoom? I would guess no.
> 
> I think it should, that's part of integration with OS. Btw, Firefox doesn't
> do that currently but that's reverse bug to this one.

I filed bug 704137 for this issue.

Comment 10

10 months ago
WFM, along the lines of bug 703465
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WORKSFORME

Comment 11

10 months ago
via bug 1088785 in firefox 41
You need to log in before you can comment on or make changes to this bug.