Last Comment Bug 703500 - Cannot drop file to <input type="file"/> if drop event is called stopPropagation()
: Cannot drop file to <input type="file"/> if drop event is called stopPropagat...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout: Form Controls (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: Masayuki Nakano [:masayuki] (Mozilla Japan)
:
: Jet Villegas (:jet)
Mentors:
data:text/html,<input type="file"><sc...
Depends on: 703150
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-17 21:18 PST by Masayuki Nakano [:masayuki] (Mozilla Japan)
Modified: 2011-11-29 05:02 PST (History)
4 users (show)
Ms2ger: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (5.97 KB, patch)
2011-11-17 21:20 PST, Masayuki Nakano [:masayuki] (Mozilla Japan)
no flags Details | Diff | Splinter Review
Patch (5.95 KB, patch)
2011-11-24 18:26 PST, Masayuki Nakano [:masayuki] (Mozilla Japan)
bugs: review+
Details | Diff | Splinter Review

Description Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-11-17 21:18:34 PST
You cannot drop file to the file input control in the URL.
Comment 1 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-11-17 21:20:51 PST
Created attachment 575388 [details] [diff] [review]
Patch

I don't know how to drop a file by synthesized event...
Comment 2 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-11-24 18:26:23 PST
Created attachment 576860 [details] [diff] [review]
Patch
Comment 3 Olli Pettay [:smaug] 2011-11-25 05:08:04 PST
Comment on attachment 576860 [details] [diff] [review]
Patch

Thanks for doing this event-listener-systemifying.

This needs tests, I think.
(Unfortunately writing dnd tests is quite painful.)
Comment 4 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-11-25 17:30:34 PST
smaug:

Do you know some examples for the tests?

* I don't know how to write the dnd test with file.
* I don't know how to get the bounding rect of native anonymous elements (text edit field and button).
Comment 5 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-11-25 17:31:08 PST
Smaug: See above comment.
Comment 6 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-11-28 20:48:18 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/fa2abb5852bd

landed without tests since I don't have idea for creating them, see comment 4.
Comment 7 Marco Bonardo [::mak] 2011-11-29 05:02:42 PST
https://hg.mozilla.org/mozilla-central/rev/fa2abb5852bd

Note You need to log in before you can comment on or make changes to this bug.