Last Comment Bug 703523 - #ifdef windows and crash reporter specific parts of browser.js
: #ifdef windows and crash reporter specific parts of browser.js
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All Linux
: -- normal (vote)
: Firefox 13
Assigned To: Mike Hommey [:glandium]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-18 02:08 PST by Mike Hommey [:glandium]
Modified: 2012-02-27 04:56 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
#ifdef some windows and crash reporter specific parts of browser.js (2.81 KB, patch)
2011-11-18 02:10 PST, Mike Hommey [:glandium]
no flags Details | Diff | Review
#ifdef some windows and crash reporter specific parts of browser.js (3.03 KB, patch)
2012-02-16 03:55 PST, Mike Hommey [:glandium]
gavin.sharp: review+
Details | Diff | Review

Description Mike Hommey [:glandium] 2011-11-18 02:08:50 PST
I wrote a script that looks for resource:// uris in the built code and checks whether the corresponding files exist, so as to detect problems with resource://gre/ used where resource:/// was meant. It turns out it also detects "problems" with imports of files that are not installed in every cases.

For instance, in browser.js, a file that is only installed in windows builds is imported, as well as a file that is only installed when the crash reporter is built.

While these are cosmetic issues, it would make my life easier if the patch i'm about to attach would be applied.
Comment 1 Mike Hommey [:glandium] 2011-11-18 02:10:07 PST
Created attachment 575411 [details] [diff] [review]
#ifdef some windows and crash reporter specific parts of browser.js
Comment 2 Mike Hommey [:glandium] 2012-02-16 03:55:41 PST
Created attachment 597767 [details] [diff] [review]
#ifdef some windows and crash reporter specific parts of browser.js
Comment 4 Marco Bonardo [::mak] 2012-02-27 04:56:47 PST
https://hg.mozilla.org/mozilla-central/rev/86f8ab61e755

Note You need to log in before you can comment on or make changes to this bug.