Closed Bug 703624 Opened 8 years ago Closed 3 years ago

Start-up crash caused by Fritz!Box 1.6.1/1.6.2 addon [@ FB_AddOn4.dll@0x27421 ][@ fb_addon4.dll@0x30741 ]

Categories

(Firefox :: Extension Compatibility, defect, critical)

9 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: marcia, Unassigned)

References

()

Details

(Keywords: crash, Whiteboard: [ticket id: CID2783798])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-c4c8a529-dc23-4ee4-b849-da9552111118 .
============================================================= 

Seen while reviewing the explosive report for Firefox 8, but happens on versions up to 9. 338 crashes in the last week in this signature. High correlation to:

100% (121/121) vs.   0% (141/97527) FB_AddOn4.dll
63% (76/121) vs.   0% (105/97527) fb_add_on@avm.de

https://crash-stats.mozilla.com/report/index/320d7e2e-b55a-4165-8003-743712111118

Frame 	Module 	Signature [Expand] 	Source
0 	kernel32.dll 	RaiseException 	
1 	FB_AddOn4.dll 	FB_AddOn4.dll@0x27421 	
2 	FB_AddOn4.dll 	FB_AddOn4.dll@0x2729c 	
3 		@0x49a227f
The referenced add-on is from AVM for its Fritz!box. Here you can find some more information:

http://service.avm.de/support/de/SKB/FRITZ-Box-7390/254:FRITZ-Box-AddOn-installieren-und-verwenden

Further it can be downloaded and installed from the AVM server:
http://download.avm.de/fritz.box/tools/fritzbox_addon/addon4ff/

This could be related to the new version AVM has shipped on Nov 14h, which has some Firefox 8 fixes included. I will reach out to their support now.
Summary: crash fb_addon4 → Crash caused by Fritz!Box 1.6.1 addon [@ FB_AddOn4.dll@0x27421]
Whiteboard: [ticket id: CID2783798]
It's always helpful to have the link to all the crashes related to this signature:

https://crash-stats.mozilla.com/report/list?range_value=7&range_unit=days&date=2011-11-23&signature=fb_addon4.dll%400x27421&version=Firefox%3A9.0b2

Given the OS it happens across Windows XP SP3, Windows Vista SP2, and Windows 7 SP1. Given the uptime numbers it's definitely a crash during start-up. Some users have already stated that in the comment. Interestingly I don't see any crashes for 64-bit Windows, so it seems to be 32-bit only.
Summary: Crash caused by Fritz!Box 1.6.1 addon [@ FB_AddOn4.dll@0x27421] → Start-up crash caused by Fritz!Box 1.6.1 addon [@ FB_AddOn4.dll@0x27421]
Marcia, could you try to reproduce the crash on our QA boxes? I tried but I'm not able to. Same applies to the support from AVM. I have already contacted some crash reporters to get more information, but in the meantime we should investigate that further.
I have found one user who is only experiencing this issue when he installs the special edition from Web.de but not with our vanilla Firefox version.

http://dl.web.de/browser/firefox/WEB.DE_Firefox_Setup.exe

I'll continue the investigation with him. Hopefully I will be able to see the crash too soon.
Waiting for further feedback from AVM and a couple of crash reporters. Hopefully I can come up with some more information in the next days.
No new updates are available yet. I will run another round of checking available crash reports.
Marcia, could you please request a correlation report for modules in those reports? That would be pretty awesome. Not sure but I have the feeling another software is causing those crashes. A lot of reports show that users have installed Office.
What version of Office? There is a lot i know...
Not sure if Office was a red herring. Lets focus on the feedback I got so far:

The crash only happens when Firefox is connected to the network during startup. The crash does not happen if Firefox starts without a network connection, but gets attached some minutes later.

So far I didn't have that many information but anyone who is involved is using a Fritz!Box 7170.

It seems that the add-on is executing some code during startup which let us crash. Could happen because of a response message from this specific Fritz!Box.

Karsten, could you run some tests with that Fritz!Box? I only have a 7270 at home.
Not all users of a system are affected by this crash. As users say in crash reports the crash does not happen after switching the Windows account. I'm still waiting for further feedback.
AVM has released a new version of the add-on a couple of days ago:
http://download.avm.de/fritz.box/tools/fritzbox_addon/addon4ff/

I will follow-up with some of the reporters and ask if that update fixes the crash for them.
Looks like there are even some more crashes with slightly different signatures:

https://crash-stats.mozilla.com/query/query?product=Firefox&version=ALL%3AALL&platform=windows&query_search=signature&query_type=contains&query=fb_addon4.dll&do_query=1
Crash Signature: [@ fb_addon4.dll@0x27421] → [@ fb_addon4.dll@0x27421 ] [@ fb_addon4.dll@0x30741 ] [@ fb_addon4.dll@0x143b ] [@ fb_addon4.dll@0x211b ] [@ fb_addon4.dll@0x6ef2f ]
[@ fb_addon4.dll@0x143b ] and [@ fb_addon4.dll@0x211b ] have way higher uptime value so those should not be related to this problem.

Anyway, so far I can find a lot of crash reports with the version 1.6.2 of the DLL. So the new version has not fixed the start-up crash.
Crash Signature: [@ fb_addon4.dll@0x27421 ] [@ fb_addon4.dll@0x30741 ] [@ fb_addon4.dll@0x143b ] [@ fb_addon4.dll@0x211b ] [@ fb_addon4.dll@0x6ef2f ] → [@ fb_addon4.dll@0x27421 ] [@ fb_addon4.dll@0x30741 ] [@ fb_addon4.dll@0x6ef2f ]
Summary: Start-up crash caused by Fritz!Box 1.6.1 addon [@ FB_AddOn4.dll@0x27421] → Start-up crash caused by Fritz!Box 1.6.1/1.6.2 addon [@ FB_AddOn4.dll@0x27421 ][@ fb_addon4.dll@0x30741 ]
Some users are reporting that the new version fixes the problem for them. But given my last comments the crash hasn't been completely fixed. But we probably could expect a dropdown of crashes.

Sadly I'm still not able to reproduce this problem even with all the information I got.
In the debugger is an error message about "Microsoft C++ Exception: Poco::NotfoundException". This code isnt used in the addon.

Does anybody have a clue about it?
http://www.appinf.com/docs/poco/

You have mentioned that the XMLHttpRequest object is used to retrieve additional update information? Probably that object makes use of the POGO library? Have you checked it with the Process Explorer?
Karsten, could you check which methods are located at the following addresses in the 1.6.2 release of the DLL?

0 kernel32.dll RaiseException 
1 FB_AddOn4.dll FB_AddOn4.dll@0x30741 
2 FB_AddOn4.dll FB_AddOn4.dll@0x305bc 
3 FB_AddOn4.dll FB_AddOn4.dll@0x3a78a 
4 FB_AddOn4.dll FB_AddOn4.dll@0x39065

For the full stack trace please open the following URL and scroll to the bottom:
https://crash-stats.mozilla.com/report/index/9e5e81ea-7a57-4a13-8b95-70c6a2120402
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
(In reply to Virtual_ManPL [:Virtual] - (ni? me) from comment #18)
> I'm marking this bug as WONTFIX per bug #1269807.

This bug report is about an addon and not plugin. Given that there was no action in past 5 years we can definitely close. But lets use incomplete, because we never figured out the underlying reason.
Resolution: WONTFIX → INCOMPLETE
For the record: the Addon was developed til 2015 with version 2.1.x, but the development was stopped in the process of the changed signature process.

AFAIK: the addon cant get installed on actual Firefox. So the problem wont occur and get closed.
I also want to add that it's safe to close as bug crashlog signature didn't appear from a long time (over half year).
You need to log in before you can comment on or make changes to this bug.