Last Comment Bug 703630 - Share option should be disabled for these protocols: about:// chrome:// file://
: Share option should be disabled for these protocols: about:// chrome:// file://
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P3 normal (vote)
: ---
Assigned To: :Margaret Leibovic
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-18 09:25 PST by Cristian Nicolae (:xti)
Modified: 2012-01-09 11:53 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
patch (3.33 KB, patch)
2011-11-22 14:54 PST, :Margaret Leibovic
blassey.bugs: review+
Details | Diff | Splinter Review

Description Cristian Nicolae (:xti) 2011-11-18 09:25:43 PST
Mozilla/5.0 (Android;Linux armv7l;rv:11.0a1)Gecko/20111118
Firefox/11.0a1 Fennec/11.0a1
Devices: Samsung Galaxy Nexus S
OS: Android 2.3.4

Steps to reproduce:
1. Open Fennec App
2. Browse to any about: page
3. Tap on device Menu button > Share

Expected result:
Share option is grayed out.

Actual result:
Share option is still available.
Comment 1 :Margaret Leibovic 2011-11-18 15:17:26 PST
I can take this.
Comment 2 :Margaret Leibovic 2011-11-22 14:54:46 PST
Created attachment 576313 [details] [diff] [review]
patch

I think the tab APIs must have gotten better since we made the original share patch, because I think it makes more sense to just use the tab to get the URL and title.
Comment 3 :Margaret Leibovic 2011-11-22 16:48:23 PST
https://hg.mozilla.org/projects/birch/rev/2ab85c27e435
Comment 4 Aaron Train [:aaronmt] 2011-11-23 08:01:24 PST
Samsung Nexus S (Android 2.3.6)
20111123040207
http://hg.mozilla.org/projects/birch/rev/cd5725c23a13

Note You need to log in before you can comment on or make changes to this bug.