Last Comment Bug 703654 - Improve document's CC Describe
: Improve document's CC Describe
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: x86_64 All
: -- normal (vote)
: ---
Assigned To: Olli Pettay [:smaug] (high review load, please consider other reviewers)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-18 10:39 PST by Olli Pettay [:smaug] (high review load, please consider other reviewers)
Modified: 2011-11-19 11:25 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.82 KB, patch)
2011-11-18 12:57 PST, Olli Pettay [:smaug] (high review load, please consider other reviewers)
continuation: review+
Details | Diff | Review

Description Olli Pettay [:smaug] (high review load, please consider other reviewers) 2011-11-18 10:39:01 PST
It could be useful to know whether the document is a data document or normal one.
Comment 1 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2011-11-18 12:57:33 PST
Created attachment 575537 [details] [diff] [review]
patch
Comment 2 Andrew McCreight [:mccr8] 2011-11-18 13:32:26 PST
While you are in there, do you know why some of these things are showing up as none?  For instance,

0x7f1d345df000 [rc=2] nsDocument ([none]) chrome://global/content/bindings/scrollbar.xml

0x7f1d321c2800 [rc=2] nsDocument ([none]) chrome://global/content/bindings/text.xml

0x7f1ce5cd5800 [rc=2] nsDocument ([none]) chrome://global/content/consoleBindings.xml

These seem like a consistent type of document.  Do you know what is going on here, smaug?
Comment 3 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2011-11-18 13:42:13 PST
XBL documents don't seem to set mDefaultElementType
Comment 4 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2011-11-18 13:43:16 PST
nor does it really make any sense, since we have only few different kinds of documents.
XML, HTML, SVG, XUL, and some document for full page media.
Comment 5 Andrew McCreight [:mccr8] 2011-11-18 13:49:52 PST
Okay, so it sounds like that should be dealt with elsewhere or not at all.
Comment 6 Andrew McCreight [:mccr8] 2011-11-18 15:37:46 PST
Comment on attachment 575537 [details] [diff] [review]
patch

Review of attachment 575537 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.
Comment 7 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2011-11-19 11:25:44 PST
https://hg.mozilla.org/mozilla-central/rev/f0e31d65d4b8

Note You need to log in before you can comment on or make changes to this bug.