Last Comment Bug 703667 - Intermittent test failures in test_breakpoint-01.js
: Intermittent test failures in test_breakpoint-01.js
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Panos Astithas [:past]
:
: James Long (:jlongster)
Mentors:
Depends on:
Blocks: 697762
  Show dependency treegraph
 
Reported: 2011-11-18 11:13 PST by Panos Astithas [:past]
Modified: 2011-12-14 02:04 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Working patch (4.16 KB, patch)
2011-11-24 08:08 PST, Panos Astithas [:past]
dcamp: review+
rcampbell: review+
Details | Diff | Splinter Review

Description Panos Astithas [:past] 2011-11-18 11:13:21 PST
From the try run at: https://tbpl.mozilla.org/?tree=Try&rev=202c0d9b0cdb

TEST-PASS | c:\talos-slave\test\build\xpcshell\tests\toolkit\devtools\debugger\tests\unit\test_nativewrappers.js | test passed (time: 94.000ms)
TEST-INFO | c:\talos-slave\test\build\xpcshell\tests\toolkit\devtools\debugger\tests\unit\test_eval-01.js | running test ...
TEST-PASS | c:\talos-slave\test\build\xpcshell\tests\toolkit\devtools\debugger\tests\unit\test_eval-01.js | test passed (time: 98.000ms)
TEST-INFO | c:\talos-slave\test\build\xpcshell\tests\toolkit\devtools\debugger\tests\unit\test_eval-02.js | running test ...
TEST-PASS | c:\talos-slave\test\build\xpcshell\tests\toolkit\devtools\debugger\tests\unit\test_eval-02.js | test passed (time: 99.000ms)
TEST-INFO | c:\talos-slave\test\build\xpcshell\tests\toolkit\devtools\debugger\tests\unit\test_eval-03.js | running test ...
TEST-PASS | c:\talos-slave\test\build\xpcshell\tests\toolkit\devtools\debugger\tests\unit\test_eval-03.js | test passed (time: 97.000ms)
TEST-INFO | c:\talos-slave\test\build\xpcshell\tests\toolkit\devtools\debugger\tests\unit\test_eval-04.js | running test ...
TEST-PASS | c:\talos-slave\test\build\xpcshell\tests\toolkit\devtools\debugger\tests\unit\test_eval-04.js | test passed (time: 100.000ms)
TEST-INFO | c:\talos-slave\test\build\xpcshell\tests\toolkit\devtools\debugger\tests\unit\test_eval-05.js | running test ...
TEST-PASS | c:\talos-slave\test\build\xpcshell\tests\toolkit\devtools\debugger\tests\unit\test_eval-05.js | test passed (time: 99.000ms)
TEST-INFO | c:\talos-slave\test\build\xpcshell\tests\toolkit\devtools\debugger\tests\unit\test_breakpoint-01.js | running test ...

command timed out: 1200 seconds without output, attempting to kill
SIGKILL failed to kill process
using fake rc=-1
program finished with exit code -1

remoteFailed: [Failure instance: Traceback from remote host -- Traceback (most recent call last):
Failure: exceptions.RuntimeError: SIGKILL failed to kill process
]
Comment 1 Panos Astithas [:past] 2011-11-21 11:25:03 PST
This issue affects Windows XP as well.
Comment 2 Panos Astithas [:past] 2011-11-24 03:50:22 PST
The cause of the failure is that the script URL reported by SpiderMonkey is this:

DBG-SERVER: Got a new script:[object Script], url: c:/Users/past/src/remote-debug/obj-i686-pc-mingw32/_tests/xpcshell/toolkit/devtools/debugger/tests/unit/test_breakpoint-01.js, startLine: 56, lineCount: 4, strictMode: undefined, function: undefined

While the path found by the test is this:

DBG-SERVER: Got: {
  "to": "conn0.context2",
  "type": "setBreakpoint",
  "location": {
    "url": "c:\\Users\\past\\src\\remote-debug\\obj-i686-pc-mingw32\\_tests\\xpcshell\\toolkit\\devtools\\debugger\\tests\\unit\\test_breakpoint-01.js",
    "line": 59
  }
}
Comment 3 Panos Astithas [:past] 2011-11-24 08:08:30 PST
Created attachment 576776 [details] [diff] [review]
Working patch

The problem stems from the fact that the paths returned by SpiderMonkey in newScript notifications are the same on all platforms, while the do_get_file helper function returns a native path. I used a pattern I've seen in other tests to differentiate between Windows and UNIX.

Rob, this is an addendum to the big review in bug 697762. You may want to review this after you get through the other parts or I could attach this patch to the other bug for your review, after Dave approves it.

Tested on OS X and Windows 7. Try run at: https://tbpl.mozilla.org/?tree=Try&rev=e2030d391d13
Comment 4 Rob Campbell [:rc] (:robcee) 2011-11-24 13:38:33 PST
it's fine here, thanks. :)
Comment 5 Panos Astithas [:past] 2011-11-25 00:26:27 PST
(In reply to Panos Astithas [:past] from comment #3)
> Tested on OS X and Windows 7. Try run at:
> https://tbpl.mozilla.org/?tree=Try&rev=e2030d391d13

16 hours later and it still hasn't started, so I fired off a new one:
https://tbpl.mozilla.org/?tree=Try&rev=18e59bc9b255
Comment 6 Rob Campbell [:rc] (:robcee) 2011-12-12 07:13:25 PST
Comment on attachment 576776 [details] [diff] [review]
Working patch

sorry for the delay on this. Patch looks fine to me.

Note You need to log in before you can comment on or make changes to this bug.