[scratchpad] errors should be inlined as a comment in the Scratchpad

RESOLVED DUPLICATE of bug 690552

Status

RESOLVED DUPLICATE of bug 690552
7 years ago
3 months ago

People

(Reporter: jwalker, Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
Enter the following in the scratchpad (I was in browser mode if that's significant)

  var f = null;
  f.foo;

Clearly that's wrong, but without reference to the Error Console, I can't tell except that none of the execute options appears to do anything.

Maybe we could have an error pulldown (like the "This scratchpad executes in the Browser context") which tells you what's wrong.
Component: Developer Tools → Developer Tools: Scratchpad
OS: Mac OS X → All
QA Contact: developer.tools → developer.tools.scratchpad
Hardware: x86 → All
Summary: Scratchpad error → Scratchpad errors are invisible to the Scratchpad UI
Whenever you execute code that fails the Web console opens automatically, or the Error console.

I agree it would be a much better UI to add a notification with the error itself. Thanks for the report!
I thought we had a bug on this, but searching doesn't turn anything up. Dupe this if anyone else can find it.

We've had multiple requests to inline error messages into the console as comments (the way the "Display" invocation method works now). I think this is a worthwhile thing to do. In practice, using the Scratchpad it's somewhat cumbersome to have to switch between the Error Console or Web Console when you hit an exception.

For bonus points, highlighting the appropriate position in the Scratchpad's selection that caused the error to occur would be highly pleasurable, though would accept this as a follow-up.
Summary: Scratchpad errors are invisible to the Scratchpad UI → [scratchpad] errors should be inlined as a comment in the Scratchpad
Whiteboard: [good-first-bug]
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 690552

Updated

4 years ago
Whiteboard: [good-first-bug]

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.