Last Comment Bug 703889 - Remove |ifndef DISABLE_XFORMS_HOOKS| since it's never defined
: Remove |ifndef DISABLE_XFORMS_HOOKS| since it's never defined
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
-- trivial (vote)
: mozilla11
Assigned To: Ed Morley [:emorley]
:
: Gregory Szorc [:gps] (away until 2017-03-20)
Mentors:
Depends on:
Blocks: 337690
  Show dependency treegraph
 
Reported: 2011-11-19 08:57 PST by Ed Morley [:emorley]
Modified: 2011-12-01 04:40 PST (History)
3 users (show)
emorley: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (6.13 KB, patch)
2011-11-19 09:12 PST, Ed Morley [:emorley]
no flags Details | Diff | Splinter Review
Patch v2 (6.20 KB, patch)
2011-11-19 10:59 PST, Ed Morley [:emorley]
ted: review+
Details | Diff | Splinter Review

Description User image Ed Morley [:emorley] 2011-11-19 08:57:03 PST
Bug 337690 added a few ifndef DISABLE_XFORMS_HOOKS conditionals (http://mxr.mozilla.org/mozilla-central/search?string=DISABLE_XFORMS_HOOKS), but it's never defined (believe it was original intended for embedders to be able to disable, but well...we know the story for embedding right now). 

By removing it, it will mean I can remove one of the extra conditionals that bug 696498 is otherwise going to have to add to toolkit-makefiles.sh to keep parity with accessible/src/Makefile.in.
Comment 1 User image Ed Morley [:emorley] 2011-11-19 09:12:51 PST
Created attachment 575678 [details] [diff] [review]
Patch v1
Comment 2 User image Ed Morley [:emorley] 2011-11-19 10:59:52 PST
Created attachment 575685 [details] [diff] [review]
Patch v2

Slight correction to content/base/public/Makefile.in
Comment 3 User image Ed Morley [:emorley] 2011-11-19 17:29:05 PST
https://tbpl.mozilla.org/?tree=Try&rev=51eba91e1c12
Comment 4 User image Ted Mielczarek [:ted.mielczarek] 2011-11-21 04:57:53 PST
Comment on attachment 575685 [details] [diff] [review]
Patch v2

Review of attachment 575685 [details] [diff] [review]:
-----------------------------------------------------------------

Interesting. I wonder where this got removed?
Comment 6 User image Marco Bonardo [::mak] 2011-12-01 04:40:46 PST
https://hg.mozilla.org/mozilla-central/rev/89db63eda545

Note You need to log in before you can comment on or make changes to this bug.