Last Comment Bug 704034 - loopstart, loopend, playcount attributes in AttributeName.java no longer exist in the spec
: loopstart, loopend, playcount attributes in AttributeName.java no longer exis...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: HTML: Parser (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: Henri Sivonen (:hsivonen)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on: 704058
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-20 18:11 PST by Matthew Gregan [:kinetik]
Modified: 2012-02-01 13:56 PST (History)
2 users (show)
hsivonen: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add loop and remove the old ones (80.68 KB, patch)
2011-11-21 06:01 PST, Henri Sivonen (:hsivonen)
bugs: review+
Details | Diff | Splinter Review

Description Matthew Gregan [:kinetik] 2011-11-20 18:11:57 PST
The loopstart, loopend, and playcount attributes were removed when the media element's looping support was changed to a simple boolean attribute "loop".

AttributeName.java is also missing the new(er) loop attribute.

I didn't understand the process to modify and regenerate this code well enough to submit a patch, but I'm happy to do so if someone can walk me through it.
Comment 1 Henri Sivonen (:hsivonen) 2011-11-20 23:39:49 PST
Thanks. I can take care of the removal and regeneration.
Comment 2 Henri Sivonen (:hsivonen) 2011-11-21 06:01:39 PST
Created attachment 575841 [details] [diff] [review]
Add loop and remove the old ones
Comment 3 Henri Sivonen (:hsivonen) 2011-11-21 06:02:30 PST
There's no test, because these pre-interned tokens affect the number of allocations the parser does. Hence, the effect of this patch isn't really testable.
Comment 4 Olli Pettay [:smaug] 2011-11-21 07:18:00 PST
Comment on attachment 575841 [details] [diff] [review]
Add loop and remove the old ones

rs=me
Comment 5 Henri Sivonen (:hsivonen) 2011-11-22 00:31:25 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/4d2f327980ff
Comment 6 Ed Morley [:emorley] 2011-11-22 09:07:51 PST
https://hg.mozilla.org/mozilla-central/rev/4d2f327980ff

Note You need to log in before you can comment on or make changes to this bug.