Inspect Element background shading in document too dark

RESOLVED FIXED in Firefox 11

Status

()

Firefox
Developer Tools: Inspector
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Bill Barry, Unassigned)

Tracking

10 Branch
Firefox 11
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0a2) Gecko/20111118 Firefox/10.0a2
Build ID: 20111118042017

Steps to reproduce:

right click - inspect element


Actual results:

opened highlighter interface, noticed background shading is too dark


Expected results:

The background shading used for the document shading when a modal popup is opened (an alert message for example) is what should be used for the background shading in the highlighter.

Comment 1

6 years ago
(In reply to Bill Barry from comment #0)

> The background shading used for the document shading when a modal popup is
> opened (an alert message for example) is what should be used for the
> background shading in the highlighter.

Hrm, this seems like a good suggestion.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

6 years ago
Created attachment 575880 [details] [diff] [review]
patch v1

Updated

6 years ago
Attachment #575880 - Flags: review?(dao)
Comment on attachment 575880 [details] [diff] [review]
patch v1

I'm not sure that a noise pattern is a wise design choice for a page inspection tool... The veil needs to be distinguishable from the highlighted area, of course, but why go further than that?

r- since tabprompts-bgtexture.png is for tab-modal prompts and may arbitrarily change in the future. It's not supposed to be used in random other places.
Attachment #575880 - Flags: review?(dao) → review-

Comment 4

6 years ago
Created attachment 575889 [details] [diff] [review]
patch v1.1 - no noise pattern

Updated

6 years ago
Attachment #575880 - Attachment is obsolete: true

Updated

6 years ago
Attachment #575889 - Flags: review?(dao)

Updated

6 years ago
Attachment #575889 - Flags: review?(dao) → review+
Attachment #575889 - Flags: review+

Updated

6 years ago
Whiteboard: [land-in-fx-team]
https://hg.mozilla.org/integration/fx-team/rev/1718a8384382
Status: NEW → ASSIGNED
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/1718a8384382
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 11
You need to log in before you can comment on or make changes to this bug.